summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-misc/asterisk/asterisk-13.38.3-r2.ebuild (renamed from net-misc/asterisk/asterisk-13.38.3-r1.ebuild)5
-rw-r--r--net-misc/asterisk/files/asterisk.tmpfiles-13.38.3-r2.conf1
-rw-r--r--net-misc/asterisk/files/asterisk.tmpfiles2.conf1
-rw-r--r--net-misc/asterisk/files/initd-13.38.3-r2 (renamed from net-misc/asterisk/files/initd-13.32.0-r1)8
4 files changed, 8 insertions, 7 deletions
diff --git a/net-misc/asterisk/asterisk-13.38.3-r1.ebuild b/net-misc/asterisk/asterisk-13.38.3-r2.ebuild
index 9c92d3c20425..12bf7e259cb9 100644
--- a/net-misc/asterisk/asterisk-13.38.3-r1.ebuild
+++ b/net-misc/asterisk/asterisk-13.38.3-r2.ebuild
@@ -109,6 +109,7 @@ QA_DT_NEEDED="/usr/lib.*/libasteriskssl[.]so[.][0-9]\+"
_make_args=(
"NOISY_BUILD=yes"
"ASTDBDIR=\$(ASTDATADIR)/astdb"
+ "ASTVARRUNDIR=/run/asterisk"
"OPTIMIZE="
"DEBUG="
"DESTDIR=${D}"
@@ -292,11 +293,11 @@ src_install() {
diropts -m 0750 -o asterisk -g asterisk
keepdir /var/log/asterisk/{cdr-csv,cdr-custom}
- newinitd "${FILESDIR}"/initd-13.32.0-r1 asterisk
+ newinitd "${FILESDIR}"/initd-13.38.3-r2 asterisk
newconfd "${FILESDIR}"/confd-13.32.0 asterisk
systemd_dounit "${FILESDIR}"/asterisk.service
- newtmpfiles "${FILESDIR}"/asterisk.tmpfiles2.conf asterisk.conf
+ newtmpfiles "${FILESDIR}"/asterisk.tmpfiles-13.38.3-r2.conf asterisk.conf
systemd_install_serviced "${FILESDIR}"/asterisk.service.conf
# Reset diropts else dodoc uses it for doc installations.
diff --git a/net-misc/asterisk/files/asterisk.tmpfiles-13.38.3-r2.conf b/net-misc/asterisk/files/asterisk.tmpfiles-13.38.3-r2.conf
new file mode 100644
index 000000000000..dc999ee65fc9
--- /dev/null
+++ b/net-misc/asterisk/files/asterisk.tmpfiles-13.38.3-r2.conf
@@ -0,0 +1 @@
+d /run/asterisk 0750 asterisk asterisk
diff --git a/net-misc/asterisk/files/asterisk.tmpfiles2.conf b/net-misc/asterisk/files/asterisk.tmpfiles2.conf
deleted file mode 100644
index ce85c7f5461a..000000000000
--- a/net-misc/asterisk/files/asterisk.tmpfiles2.conf
+++ /dev/null
@@ -1 +0,0 @@
-d /var/run/asterisk 0750 asterisk asterisk
diff --git a/net-misc/asterisk/files/initd-13.32.0-r1 b/net-misc/asterisk/files/initd-13.38.3-r2
index 2a7387dc2eb0..8a4555be7ecd 100644
--- a/net-misc/asterisk/files/initd-13.32.0-r1
+++ b/net-misc/asterisk/files/initd-13.38.3-r2
@@ -1,5 +1,5 @@
#!/sbin/openrc-run
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
extra_started_commands="forcestop reload"
@@ -30,7 +30,7 @@ setup_svc_variables()
local t
ast_instancename=asterisk
- ast_rundir=/var/run/${RC_SVCNAME}
+ ast_rundir=/run/${RC_SVCNAME}
ast_logdir=/var/log/${RC_SVCNAME}
ast_spooldir=/var/spool/${RC_SVCNAME}
ast_confdir=/etc/${RC_SVCNAME/.//}
@@ -291,7 +291,7 @@ wrapperstop() {
# Accomodate system upgrades (so a previous version of the wrapper script that still uses a pid file may be running).
if [ -r "${ast_rundir}/wrapper_loop.pid" ]; then
ebegin "Killing ${ast_instancename} wrapper script"
- kill "$(cat /var/run/asterisk/wrapper_loop.pid)"
+ kill "$(cat /run/asterisk/wrapper_loop.pid)"
eend $?
fi
@@ -313,7 +313,7 @@ forcestop() {
wrapperstop
ebegin "Stopping ${ast_instancename} PBX"
- start-stop-daemon --stop --pidfile /var/run/asterisk/asterisk.pid
+ start-stop-daemon --stop --pidfile /run/asterisk/asterisk.pid
eend $?
}