summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-editors/logseq-desktop-bin/Manifest1
-rw-r--r--app-editors/logseq-desktop-bin/logseq-desktop-bin-0.10.6.ebuild90
-rw-r--r--profiles/features/musl/package.mask4
3 files changed, 95 insertions, 0 deletions
diff --git a/app-editors/logseq-desktop-bin/Manifest b/app-editors/logseq-desktop-bin/Manifest
index 610af32627ea..044d6e7a3fae 100644
--- a/app-editors/logseq-desktop-bin/Manifest
+++ b/app-editors/logseq-desktop-bin/Manifest
@@ -1,2 +1,3 @@
DIST logseq-desktop-bin-0.10.3.zip 196558568 BLAKE2B b031283954067f230fad205c3a1ffd302b1a74288694fcd3e566f3403a541a5bcd406e82f75dc8b0f2cccd12f284dd6ab32a4302e0baf30e967c0787b5718e9d SHA512 615f3a6534aab05d658c9f89f9d02ea621b754ce57b919b105226fb7bcfd5b8cacf7ad1644a4ea233148f5c92708830bddf7eb1226d0c759f28906ca8dbb1ec1
DIST logseq-desktop-bin-0.10.5.zip 196686745 BLAKE2B 9dfc64cf71037a4910dadc48f9e8ef9ff18bf5b34d02667a370e7393b38afcd97b45ae3dcc48ab577a3f25aeb01f74867b92ab6216feb3439e180a3671392f34 SHA512 56ffcdf0394ea064a53f9338d5a7cec54908b7c6f3176f15f6a009d68230cb58fb4d2ec3ac72f752a96ecf0025b06ad7aaa70e6e19623f5e7e95e12b1567c0f3
+DIST logseq-desktop-bin-0.10.6.zip 189610228 BLAKE2B 96dfa264c7018d973849cc52775c8dfccf3284f0880efba596697af21b0ae949fbdf39d1a0abc4e46242f58344c93075de6320460e3518bcdcd76b74c4690dd0 SHA512 42c7823973def77484f0f3ec21a47dad4acf02d60d40c1aeae73b583b6cbae8fea911692aac069c6daa657b8849e1129f13f328a4e1f991b289e9805a612a368
diff --git a/app-editors/logseq-desktop-bin/logseq-desktop-bin-0.10.6.ebuild b/app-editors/logseq-desktop-bin/logseq-desktop-bin-0.10.6.ebuild
new file mode 100644
index 000000000000..e1b0af6cf3f7
--- /dev/null
+++ b/app-editors/logseq-desktop-bin/logseq-desktop-bin-0.10.6.ebuild
@@ -0,0 +1,90 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CHROMIUM_LANGS="
+ af am ar bg bn ca cs da de el en-GB en-US es-419 es et fa fil fi fr gu he hi
+ hr hu id it ja kn ko lt lv ml mr ms nb nl pl pt-BR pt-PT ro ru sk sl sr sv sw
+ ta te th tr uk ur vi zh-CN zh-TW
+"
+
+inherit chromium-2 desktop unpacker xdg
+
+DESCRIPTION="A privacy-first, open-source platform for knowledge sharing and management."
+HOMEPAGE="https://github.com/logseq/logseq"
+SRC_URI="https://github.com/logseq/logseq/releases/download/${PV}/logseq-linux-x64-${PV}.zip -> ${P}.zip"
+S="${WORKDIR}/Logseq-linux-x64"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+
+RESTRICT="mirror splitdebug"
+
+RDEPEND="
+ dev-libs/openssl:0/3
+ media-libs/alsa-lib
+ media-libs/mesa
+ net-misc/curl
+ net-print/cups
+ sys-apps/dbus
+ sys-libs/glibc
+ sys-libs/zlib
+ x11-libs/cairo
+ x11-libs/gtk+:3
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXrandr
+ x11-libs/libdrm
+ x11-libs/libxcb
+ x11-libs/libxkbcommon
+ x11-libs/pango
+"
+BDEPEND="
+ app-arch/unzip
+"
+
+QA_PREBUILT="*"
+
+src_configure() {
+ default
+ chromium_suid_sandbox_check_kernel_config
+}
+
+src_prepare() {
+ default
+ pushd locales > /dev/null || die
+ chromium_remove_language_paks
+ popd > /dev/null || die
+}
+
+src_install() {
+ exeinto /opt/logseq-desktop
+ doexe Logseq chrome-sandbox libEGL.so libffmpeg.so libGLESv2.so libvk_swiftshader.so libvulkan.so.1
+
+ insinto /opt/logseq-desktop
+ doins chrome_100_percent.pak chrome_200_percent.pak icudtl.dat resources.pak snapshot_blob.bin \
+ v8_context_snapshot.bin version vk_swiftshader_icd.json
+ insopts -m0755
+ doins -r locales resources
+
+ # Chrome-sandbox requires the setuid bit to be specifically set
+ # see https://github.com/electron/electron/issues/17972
+ fowners root /opt/logseq-desktop/chrome-sandbox
+ fperms 4711 /opt/logseq-desktop/chrome-sandbox
+
+ # Crashpad is included in the package once in a while and when it does, it must be installed.
+ # See #903616 and #890595
+ [[ -x chrome_crashpad_handler ]] && doins chrome_crashpad_handler
+
+ dosym ../logseq-desktop/Logseq /opt/bin/logseq
+
+ make_desktop_entry "/opt/bin/logseq %U" Logseq logseq Office \
+ "StartupWMClass=logseq\nTerminal=false\nMimeType=x-scheme-handler/logseq"
+ # some releases do not have an icon included, but we dont fail if that happens
+ doicon resources/app/icons/logseq.png || true
+}
diff --git a/profiles/features/musl/package.mask b/profiles/features/musl/package.mask
index cc8da1c051a2..4ac9c258ccbb 100644
--- a/profiles/features/musl/package.mask
+++ b/profiles/features/musl/package.mask
@@ -1,6 +1,10 @@
# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
+# Marc Schiffbauer <mschiff@gentoo.org> (2024-02-16)
+# Binary package, which is compiled against glibc
+app-editors/logseq-desktop-bin
+
# Christopher Fore <csfore@posteo.net> (2024-01-24)
# >=sys-fs/bcachefs-tools-1.4.1 uses functions currently not in Musl
# https://github.com/koverstreet/bcachefs-tools/issues/213