summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-base/xorg-proto/Manifest1
-rw-r--r--x11-base/xorg-proto/xorg-proto-2021.3.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/x11-base/xorg-proto/Manifest b/x11-base/xorg-proto/Manifest
index b204e149f776..37c01406fc9b 100644
--- a/x11-base/xorg-proto/Manifest
+++ b/x11-base/xorg-proto/Manifest
@@ -1,3 +1,4 @@
DIST keysym-generator.py 15899 BLAKE2B c0d3fc72d1d12d21353ea9c4c397897784ebe10e917b03248badccc1ae35b59b405b6a2e682c800a8f1ae56a07819c03f2c5adfcc8e036d1237d0a697b6e3f0d SHA512 f51551720dee0e86b26f631f7ba7179b301a8b71c5a25cb8ec898eedbfb8a326533df9818103f7b1fabd2b5f1ecaeb72d5f2d4cedc46be8e954921246d210b9b
DIST xorgproto-2020.1.tar.gz 1081369 BLAKE2B 1bed8d65499926a830180ee1fce5e5e57a276a6412231508eabb6c5eea5ee20dcce4046fc82203d5be88d1f24fb7919289393551d339e5cf5cb80b1c14f22c42 SHA512 d0bc3aec517fd00fa5fd32a5715760c34810a19154e10fb1f92f2e2fe7f26136f7ba9b76b47fcd37c3c4796663154f4e5abf6a18dd634619b0f718f3e4737ae9
DIST xorgproto-2021.2.tar.gz 1125607 BLAKE2B ece6722de10779434395a26bb4f2421548af39ac96750d721320ed4a592c7119943b988c812cccdeb09c97b3ac51b78a5660ada5ba3489d0705777d1217818a5 SHA512 5e9728a08e934a01143bf5790fb098ab5358501a67786f0eeca875a25ee030d77b41c1481d5e501a6a82a205cfd62063ffb65344e83818b1e31a9133547e5fba
+DIST xorgproto-2021.3.tar.gz 1130599 BLAKE2B 21aa84621984cd2635871c059ecbfe2c6290c74a3569f15cdce6080dd7e4106726ae9338112c075c8f64332ecb555a4ccb666bd7bf7e9bb1156b4591e5f37908 SHA512 0c2610551cc180b619611e0ad344e1a01cb0e5e83b3c8643cd6dbe19d8acc3a22e7c1522855923159dd753e4458c9f2d65b709bb045b27e17b83aa8c264e3d5a
diff --git a/x11-base/xorg-proto/xorg-proto-2021.3.ebuild b/x11-base/xorg-proto/xorg-proto-2021.3.ebuild
new file mode 100644
index 000000000000..2c391aa1de4d
--- /dev/null
+++ b/x11-base/xorg-proto/xorg-proto-2021.3.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+
+MY_PN="${PN/xorg-/xorg}"
+MY_P="${MY_PN}-${PV}"
+
+EGIT_REPO_URI="https://gitlab.freedesktop.org/xorg/proto/${MY_PN}.git"
+
+if [[ ${PV} = 9999* ]]; then
+ GIT_ECLASS="git-r3"
+fi
+
+inherit ${GIT_ECLASS} meson python-any-r1
+
+DESCRIPTION="X.Org combined protocol headers"
+HOMEPAGE="https://gitlab.freedesktop.org/xorg/proto/xorgproto"
+if [[ ${PV} = 9999* ]]; then
+ SRC_URI=""
+else
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~x64-macos ~x64-solaris"
+ SRC_URI="https://xorg.freedesktop.org/archive/individual/proto/${MY_P}.tar.gz"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ test? (
+ $(python_gen_any_dep '
+ dev-python/python-libevdev[${PYTHON_USEDEP}]
+ ')
+ )
+"
+RDEPEND=""
+
+python_check_deps() {
+ has_version -b "dev-python/python-libevdev[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}