summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-libs/branca/Manifest1
-rw-r--r--sci-libs/branca/branca-0.4.2.ebuild30
-rw-r--r--sci-libs/branca/files/branca-0.4.2-test.patch14
-rw-r--r--sci-libs/branca/metadata.xml16
4 files changed, 61 insertions, 0 deletions
diff --git a/sci-libs/branca/Manifest b/sci-libs/branca/Manifest
new file mode 100644
index 000000000000..ee2664a83179
--- /dev/null
+++ b/sci-libs/branca/Manifest
@@ -0,0 +1 @@
+DIST branca-0.4.2.tar.gz 59337 BLAKE2B 7d7f101a3dcc07c0210f968da2ed41f4a75177b625ce46252024da7dbba82618dbe60886c615c9461c724af76b45c7710f631bc65d5743cee7f18a2052f9db49 SHA512 cefb3b0f41d515492902ef4046cf7f10b638aca8409f5b08f201550ed5a971a441d13243b1ce38ac0b8c0f76cde1329955d26c1856e1f3c25014a6ce0d805fd6
diff --git a/sci-libs/branca/branca-0.4.2.ebuild b/sci-libs/branca/branca-0.4.2.ebuild
new file mode 100644
index 000000000000..827ed2ca9acb
--- /dev/null
+++ b/sci-libs/branca/branca-0.4.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8,9} )
+inherit distutils-r1
+
+DESCRIPTION="spinoff from folium, host the non-map-specific features."
+HOMEPAGE="https://github.com/python-visualization/branca"
+SRC_URI="${HOMEPAGE}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+PATCHES=( "${FILESDIR}"/${P}-test.patch )
+
+RDEPEND="dev-python/jinja[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/selenium[${PYTHON_USEDEP}]
+ )"
+BDEPEND=""
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest -m 'not headless'
+}
diff --git a/sci-libs/branca/files/branca-0.4.2-test.patch b/sci-libs/branca/files/branca-0.4.2-test.patch
new file mode 100644
index 000000000000..8c1525d69bf7
--- /dev/null
+++ b/sci-libs/branca/files/branca-0.4.2-test.patch
@@ -0,0 +1,14 @@
+--- a/setup.cfg 2021-07-30 21:13:41.303271681 +0200
++++ b/setup.cfg 2021-07-30 21:13:49.133164898 +0200
+@@ -11,11 +11,6 @@
+ parentdir_prefix =
+
+ [tool:pytest]
+-flake8-max-line-length = 105
+-flake8-ignore =
+- docs/* ALL
+- versioneer.py ALL
+- branca/_version.py ALL
+ markers =
+ headless: mark headless tests (deselect with '-m "not headless"')
+
diff --git a/sci-libs/branca/metadata.xml b/sci-libs/branca/metadata.xml
new file mode 100644
index 000000000000..6e83a06af3af
--- /dev/null
+++ b/sci-libs/branca/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>tupone@gentoo.org</email>
+ <name>Tupone Alfredo</name>
+ </maintainer>
+ <longdescription lang="en">
+ This library is a spinoff from folium, that would host the non-map-specific features.
+ It may become a HTML+JS generation library in the future.
+ It is based on Jinja2 only.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">python-visualization/branca</remote-id>
+ </upstream>
+</pkgmetadata>