summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-cpp/glog/glog-0.3.3-r1.ebuild7
-rw-r--r--dev-cpp/glog/glog-0.3.4-r1.ebuild7
-rw-r--r--dev-cpp/glog/glog-0.3.4.ebuild7
3 files changed, 6 insertions, 15 deletions
diff --git a/dev-cpp/glog/glog-0.3.3-r1.ebuild b/dev-cpp/glog/glog-0.3.3-r1.ebuild
index 3b6207ec2075..667d65726491 100644
--- a/dev-cpp/glog/glog-0.3.3-r1.ebuild
+++ b/dev-cpp/glog/glog-0.3.3-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="4"
@@ -16,10 +16,7 @@ IUSE="gflags static-libs unwind test"
RDEPEND="gflags? ( >=dev-cpp/gflags-2.0-r1[${MULTILIB_USEDEP}] )
unwind? ( sys-libs/libunwind )"
DEPEND="${RDEPEND}
- test? (
- >=dev-cpp/gmock-1.7.0-r1[${MULTILIB_USEDEP}]
- >=dev-cpp/gtest-1.6.0-r2[${MULTILIB_USEDEP}]
- )"
+ test? ( >=dev-cpp/gtest-1.8.0[${MULTILIB_USEDEP}] )"
src_prepare() {
epatch "${FILESDIR}"/${PN}-0.3.2-avoid-inline-asm.patch
diff --git a/dev-cpp/glog/glog-0.3.4-r1.ebuild b/dev-cpp/glog/glog-0.3.4-r1.ebuild
index 522feb232f90..ad7b6587ddb3 100644
--- a/dev-cpp/glog/glog-0.3.4-r1.ebuild
+++ b/dev-cpp/glog/glog-0.3.4-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -18,10 +18,7 @@ RDEPEND="
gflags? ( >=dev-cpp/gflags-2.0-r1[${MULTILIB_USEDEP}] )
unwind? ( sys-libs/libunwind[${MULTILIB_USEDEP}] )"
DEPEND="${RDEPEND}
- test? (
- >=dev-cpp/gmock-1.7.0-r1[${MULTILIB_USEDEP}]
- >=dev-cpp/gtest-1.6.0-r2[${MULTILIB_USEDEP}]
- )"
+ test? ( >=dev-cpp/gtest-1.8.0[${MULTILIB_USEDEP}] )"
PATCHES=(
"${FILESDIR}"/${PN}-0.3.2-avoid-inline-asm.patch
diff --git a/dev-cpp/glog/glog-0.3.4.ebuild b/dev-cpp/glog/glog-0.3.4.ebuild
index a6e1d7719cb0..a6b6ee4e3fb4 100644
--- a/dev-cpp/glog/glog-0.3.4.ebuild
+++ b/dev-cpp/glog/glog-0.3.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="5"
@@ -17,10 +17,7 @@ IUSE="gflags static-libs unwind test"
RDEPEND="gflags? ( >=dev-cpp/gflags-2.0-r1[${MULTILIB_USEDEP}] )
unwind? ( sys-libs/libunwind )"
DEPEND="${RDEPEND}
- test? (
- >=dev-cpp/gmock-1.7.0-r1[${MULTILIB_USEDEP}]
- >=dev-cpp/gtest-1.6.0-r2[${MULTILIB_USEDEP}]
- )"
+ test? ( >=dev-cpp/gtest-1.8.0[${MULTILIB_USEDEP}] )"
src_prepare() {
epatch "${FILESDIR}"/${PN}-0.3.2-avoid-inline-asm.patch