summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-text/bibletime/bibletime-3.0.ebuild12
1 files changed, 10 insertions, 2 deletions
diff --git a/app-text/bibletime/bibletime-3.0.ebuild b/app-text/bibletime/bibletime-3.0.ebuild
index 2291044e8729..a36584eb0509 100644
--- a/app-text/bibletime/bibletime-3.0.ebuild
+++ b/app-text/bibletime/bibletime-3.0.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
VIRTUALX_REQUIRED=test
-inherit cmake virtualx
+inherit cmake virtualx xdg-utils
DESCRIPTION="Qt Bible-study application using the SWORD library"
HOMEPAGE="http://bibletime.info/"
@@ -66,3 +66,11 @@ src_configure() {
src_test() {
virtx cmake_src_test || die "Test run has failed"
}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}