summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/pydyf/Manifest1
-rw-r--r--dev-python/pydyf/pydyf-0.7.0.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/pydyf/Manifest b/dev-python/pydyf/Manifest
index 031944e0dee7..a00496e7a639 100644
--- a/dev-python/pydyf/Manifest
+++ b/dev-python/pydyf/Manifest
@@ -1 +1,2 @@
DIST pydyf-0.6.0.tar.gz 16027 BLAKE2B 8dcbcb0cdd6f27aae53d74c1f60646bda17b05862d3fcdfdf18d459fd0f419f9418488bddf210f29cca945adba3670b41d67d958ebff031934db57ab954ab554 SHA512 2819aab7b9e72abd02b8658923b595fe0775f341a829b732e1448c02a4aeb8538a7eb5d42307499e255e240c00f8a991687f42122348bcc39e6660c8c27e4f85
+DIST pydyf-0.7.0.tar.gz 16186 BLAKE2B 8dec96ba9d263ed503f1b13c8cfc6eafbd66c7d1cc080b5a18476c93063c0099c46c3362bbeeb71a796fbfdadbd2007c9858b21053464adc243a7d1f7a2f9a54 SHA512 cfc58170b57684cbf5233ca48798881a980af0b3e3fdc8da91c5932affee0365f1e9d535df1f983e0f16c6e612ec5048c91d236bf69b6fae46c7e59f6c2388d0
diff --git a/dev-python/pydyf/pydyf-0.7.0.ebuild b/dev-python/pydyf/pydyf-0.7.0.ebuild
new file mode 100644
index 000000000000..390195e90def
--- /dev/null
+++ b/dev-python/pydyf/pydyf-0.7.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A low-level PDF generator"
+HOMEPAGE="
+ https://pypi.org/project/pydyf/
+ https://github.com/CourtBouillon/pydyf/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ test? (
+ app-text/ghostscript-gpl
+ dev-python/pillow[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest