summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-i18n/ibus-table/Manifest1
-rw-r--r--app-i18n/ibus-table/ibus-table-1.17.4.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/app-i18n/ibus-table/Manifest b/app-i18n/ibus-table/Manifest
index 167677cd03bf..8afc6f6a01e6 100644
--- a/app-i18n/ibus-table/Manifest
+++ b/app-i18n/ibus-table/Manifest
@@ -1 +1,2 @@
DIST ibus-table-1.17.3.tar.gz 1545954 BLAKE2B 67d21a606f312e9e0e686faec73031619e2075647f4fff73b3ffbe560574d9fc3c7f36a0bb41924f31da9b0a49eab274e4b0a463a38026f829155fad4ba839e3 SHA512 1945b902391d4863b0efadc088d275bc3003d63b1c15af939d2991506d4bc1f93166881eb16c0c77c2caf2867ef56144f04aa0e05892c5a3c78be4696b30ae72
+DIST ibus-table-1.17.4.tar.gz 1559267 BLAKE2B c3c48dcebc345e658a2e6a10b13f1a0312c2e906de0bd78ee0fcbe97379663b21c6f0dbe45d029343faea340f2d031937c6f41c2a113009b60e75d108b884244 SHA512 fde595635cf50e40657b394f61173360cd9f67aa212459f14d96e08805deb164931dddd564201653a85a2973b2e6429bd2683af96974c7cee5dae3067833efd3
diff --git a/app-i18n/ibus-table/ibus-table-1.17.4.ebuild b/app-i18n/ibus-table/ibus-table-1.17.4.ebuild
new file mode 100644
index 000000000000..fa1d06003138
--- /dev/null
+++ b/app-i18n/ibus-table/ibus-table-1.17.4.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_REQ_USE="sqlite(+)"
+
+inherit gnome2-utils python-single-r1 xdg
+
+DESCRIPTION="Tables engines for IBus"
+HOMEPAGE="https://github.com/ibus/ibus/wiki"
+SRC_URI="https://github.com/kaio/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+RESTRICT="test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ app-i18n/ibus[python(+),${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ ')
+ virtual/libiconv
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ python_fix_shebang .
+
+ default
+}
+
+src_configure() {
+ econf $(use_enable nls)
+}
+
+pkg_preinst() {
+ xdg_pkg_preinst
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}