summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-misc/sphinx/Manifest2
-rw-r--r--app-misc/sphinx/sphinx-2.0.10.ebuild103
2 files changed, 0 insertions, 105 deletions
diff --git a/app-misc/sphinx/Manifest b/app-misc/sphinx/Manifest
index 2e5519e7a36a..311a7412d3d5 100644
--- a/app-misc/sphinx/Manifest
+++ b/app-misc/sphinx/Manifest
@@ -1,4 +1,2 @@
-DIST libstemmer_c-20091122.tgz 129207 BLAKE2B 8ebf49f4d2b7dd5d0e56e5a032f16e807cc7c400b4c4a0e73601ace17908b441789ceca87c0258c17b4201b43751df5fad890fecc3a1aaeba60f83c80beecf32 SHA512 d1b2203dcc3d0f421526d3ec2f7e04889f93221222efe50501b4a1c7e74dfc51905141d4ada5a76feab5cec8dbc64f55dd55b53f6e89f658c67e72dc6667091d
-DIST sphinx-2.0.10-release.tar.gz 2016687 BLAKE2B 176a14c2e1ecc859f5499eab2b2ee9cb9047ec6d07b407c0dbd3a405a9ca6198e1480166a245f7f523e3c3555bf8fe7ad7f0733bce5371f1b35ce6894dfafa6c SHA512 d22a0ce261cd6decda2e9e91fc9806699c818bb45a9c9c5e11a0944a698d47b5862c577eb55e7b57dd208db982e7f8bfc7163af37aaedc1c537841aff1409952
DIST sphinx-2.1.9-release.tar.gz 2443797 BLAKE2B d741d0bc915ece01c3ddcbfacd44f34ef5d772d2bdf07aecb3a704dc0c5ef551e9d3829af200b1c96e41be2a037552c28a83647af78e827d7a9627f1d9d536a8 SHA512 7f4538011db5d68bd00c00978d476f780fc2d355113bd2819996bacbaef90b0de5b14c946a9aad83157b818d9b6b01ee0a26bc72862cfd151067ad9967c18f56
DIST sphinx-2.2.11-release.tar.gz 3061998 BLAKE2B 63abdf3d08046ebafcdfd67d3445325b9b127e4dd66ba9d36b3b7053ba80f1f3308b74fd1e01caae6174850e1db22c743454894584bad4a4bec78d533a002668 SHA512 cf1a262a5b0fbf0bd2827ec6ec629edeaf709ce855a6e7b509b65342baaeb26c02717ca63f1578d32c83d21e2fd6d1e92dceb34660e6351b93cd96fd4e623689
diff --git a/app-misc/sphinx/sphinx-2.0.10.ebuild b/app-misc/sphinx/sphinx-2.0.10.ebuild
deleted file mode 100644
index b33e16db8467..000000000000
--- a/app-misc/sphinx/sphinx-2.0.10.ebuild
+++ /dev/null
@@ -1,103 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-WANT_AUTOMAKE=1.15
-
-inherit eutils autotools toolchain-funcs
-
-#MY_P=${P/_/-}
-MY_P=${P}-release
-
-# This has been added by Gentoo, to explicitly version libstemmer.
-# It is the date that http://snowball.tartarus.org/dist/libstemmer_c.tgz was
-# fetched.
-STEMMER_PV="20091122"
-DESCRIPTION="Full-text search engine with support for MySQL and PostgreSQL"
-HOMEPAGE="http://www.sphinxsearch.com/"
-SRC_URI="http://sphinxsearch.com/files/${MY_P}.tar.gz
- stemmer? ( mirror://gentoo/libstemmer_c-${STEMMER_PV}.tgz )"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc x86 ~amd64-linux ~ppc-macos ~x86-macos ~sparc-solaris ~sparc64-solaris"
-IUSE="debug id64 mysql odbc postgres stemmer test"
-
-RDEPEND="mysql? ( virtual/mysql )
- postgres? ( dev-db/postgresql:* )
- odbc? ( dev-db/unixODBC )
- virtual/libiconv"
-DEPEND="${RDEPEND}
- test? ( dev-lang/php )"
-
-S=${WORKDIR}/${MY_P}
-
-src_unpack() {
- unpack ${MY_P}.tar.gz
- if use stemmer; then
- cd "${S}"
- unpack libstemmer_c-${STEMMER_PV}.tgz
- fi
-}
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-2.0.1_beta-darwin8.patch
-
- # drop nasty hardcoded search path breaking Prefix
- # We patch configure directly since otherwise we need to run
- # eautoreconf twice and that causes problems, bug 425380
- sed -i -e 's/\/usr\/local\//\/someplace\/nonexisting\//g' configure || die
-
- # Fix QA compilation warnings.
- sed -i -e '19i#include <string.h>' api/libsphinxclient/test.c || die
-
- pushd api/libsphinxclient || die
- eautoreconf
- popd || die
-}
-
-src_configure() {
- # fix libiconv detection
- use !elibc_glibc && export ac_cv_search_iconv=-liconv
-
- econf \
- --sysconfdir="${EPREFIX}/etc/${PN}" \
- $(use_enable id64) \
- $(use_with debug) \
- $(use_with mysql) \
- $(use_with odbc unixodbc) \
- $(use_with postgres pgsql) \
- $(use_with stemmer libstemmer)
-
- cd api/libsphinxclient || die
- econf STRIP=:
-}
-
-src_compile() {
- emake AR="$(tc-getAR)" || die "emake failed"
-
- emake -j 1 -C api/libsphinxclient || die "emake libsphinxclient failed"
-}
-
-src_test() {
- elog "Tests require access to a live MySQL database and may require configuration."
- elog "You will find them in /usr/share/${PN}/test and they require dev-lang/php"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "install failed"
- emake DESTDIR="${D}" -C api/libsphinxclient install || die "install libsphinxclient failed"
-
- dodoc doc/*
-
- dodir /var/lib/sphinx
- dodir /var/log/sphinx
-
- newinitd "${FILESDIR}"/searchd.rc searchd
-
- if use test; then
- insinto /usr/share/${PN}
- doins -r test
- fi
-}