summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-engines/openmw/files/openmw-0.47.0-gcc13.patch22
-rw-r--r--games-engines/openmw/openmw-0.47.0-r2.ebuild1
2 files changed, 23 insertions, 0 deletions
diff --git a/games-engines/openmw/files/openmw-0.47.0-gcc13.patch b/games-engines/openmw/files/openmw-0.47.0-gcc13.patch
new file mode 100644
index 000000000000..bb99b7c77880
--- /dev/null
+++ b/games-engines/openmw/files/openmw-0.47.0-gcc13.patch
@@ -0,0 +1,22 @@
+Fix missing includes causing issues with gcc13.
+https://bugs.gentoo.org/905337
+--- a/apps/openmw/mwinput/controlswitch.hpp
++++ b/apps/openmw/mwinput/controlswitch.hpp
+@@ -3,6 +3,7 @@
+
+ #include <map>
+ #include <string>
++#include <cinttypes>
+
+ namespace ESM
+ {
+--- a/components/misc/utf8stream.hpp
++++ b/components/misc/utf8stream.hpp
+@@ -3,6 +3,7 @@
+
+ #include <cstring>
+ #include <tuple>
++#include <cinttypes>
+
+ class Utf8Stream
+ {
diff --git a/games-engines/openmw/openmw-0.47.0-r2.ebuild b/games-engines/openmw/openmw-0.47.0-r2.ebuild
index 91dd01645c25..98cbd99efd3a 100644
--- a/games-engines/openmw/openmw-0.47.0-r2.ebuild
+++ b/games-engines/openmw/openmw-0.47.0-r2.ebuild
@@ -65,6 +65,7 @@ PATCHES=(
"${FILESDIR}"/openmw-0.47.0-mygui-license.patch
"${FILESDIR}"/openmw-0.47.0-sigstksz.patch
"${FILESDIR}"/openmw-0.47.0-gcc12.patch
+ "${FILESDIR}"/openmw-0.47.0-gcc13.patch
)
src_prepare() {