summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-crypt/adcli/Manifest1
-rw-r--r--app-crypt/adcli/adcli-0.9.2.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/app-crypt/adcli/Manifest b/app-crypt/adcli/Manifest
index f3ecd53d43f9..79c8bda78f38 100644
--- a/app-crypt/adcli/Manifest
+++ b/app-crypt/adcli/Manifest
@@ -1 +1,2 @@
DIST adcli-0.9.1.tar.bz2 89684 BLAKE2B deaf6d3a13ad29c77a35b9f9c195dd646f384ad7c9782c15b50b26efceabae268bbb287d488ec7ed8d783d92ce7d8399f05898d30201d0d7fab7c0369c22fce1 SHA512 7e41fb51bfcb8837f9e5f6fd1fceacece0762c237dbc0f58dd581e2be8841d7a613d57507aea4534a66a2bd10ef4d01c4e04885437038c71238739db6e357d6e
+DIST adcli-0.9.2.tar.bz2 93680 BLAKE2B b5958b276ee43a0ee54aa922f27ed266d4e9fbd1c86e0c007dac9fcf9cc022e1b3ba043b782fceb00066be2577390773dc99fb8d476a6b5e6523d44d008fb667 SHA512 ae8414a0af389b6845dd92d41446a80a9dc1734b874175323c0e491d99944eab442b95ae6d3a29fc69638d2e73bf8d2c369f6fa50e9ed3968527444b78606286
diff --git a/app-crypt/adcli/adcli-0.9.2.ebuild b/app-crypt/adcli/adcli-0.9.2.ebuild
new file mode 100644
index 000000000000..3c224b561e82
--- /dev/null
+++ b/app-crypt/adcli/adcli-0.9.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Tool for performing actions on an Active Directory domain"
+HOMEPAGE="https://www.freedesktop.org/software/realmd/adcli/adcli.html"
+SRC_URI="https://gitlab.freedesktop.org/realmd/adcli/-/archive/${PV}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND="
+ app-crypt/mit-krb5
+ net-nds/openldap:=[sasl]"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ doc? (
+ app-text/docbook-xml-dtd:4.3
+ app-text/xmlto
+ dev-libs/libxslt
+ )"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable doc)
+}