summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-print/poster/files/poster-20060221-fix_duplicate_DocumentMedia.patch19
-rw-r--r--net-print/poster/poster-20060221-r1.ebuild26
2 files changed, 45 insertions, 0 deletions
diff --git a/net-print/poster/files/poster-20060221-fix_duplicate_DocumentMedia.patch b/net-print/poster/files/poster-20060221-fix_duplicate_DocumentMedia.patch
new file mode 100644
index 000000000000..52584a9507a3
--- /dev/null
+++ b/net-print/poster/files/poster-20060221-fix_duplicate_DocumentMedia.patch
@@ -0,0 +1,19 @@
+See https://bugs.gentoo.org/show_bug.cgi?id=471270
+
+--- a/poster.c 2013-05-25 21:41:53.000000000 +0200
++++ b/poster.c 2013-05-25 21:43:41.000000000 +0200
+@@ -812,8 +812,12 @@
+ if (!strncmp( c, "(atend)", 7)) atend = 1;
+ else
+ { /* pass this DSC to output */
+- puts( buf);
+- dsc_cont = 1;
++ /* if it is not another DocumentMedia comment */
++ if (strncmp( buf, "%%DocumentMedia", 15))
++ {
++ puts( buf);
++ dsc_cont = 1;
++ }
+ }
+ }
+ else if ( !strncmp( buf, "%%Pages:", 8 ) )
diff --git a/net-print/poster/poster-20060221-r1.ebuild b/net-print/poster/poster-20060221-r1.ebuild
new file mode 100644
index 000000000000..0c751446686c
--- /dev/null
+++ b/net-print/poster/poster-20060221-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit toolchain-funcs
+
+DESCRIPTION="small utility for making a poster from an EPS file or a one-page PS document"
+SRC_URI="mirror://kde/printing/${P}.tar.bz2"
+HOMEPAGE="https://printing.kde.org/downloads"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+src_compile(){
+ $(tc-getCC) ${CFLAGS} ${LDFLAGS} ${PN}.c -lm -o ${PN} || die
+}
+
+src_install() {
+ dobin ${PN}
+ doman ${PN}.1
+ dodoc README ChangeLog
+}