summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-shells/nushell/metadata.xml2
-rw-r--r--app-shells/nushell/nushell-0.74.0-r1.ebuild (renamed from app-shells/nushell/nushell-0.74.0.ebuild)12
2 files changed, 6 insertions, 8 deletions
diff --git a/app-shells/nushell/metadata.xml b/app-shells/nushell/metadata.xml
index b45c411eda95..f8d129c053aa 100644
--- a/app-shells/nushell/metadata.xml
+++ b/app-shells/nushell/metadata.xml
@@ -12,6 +12,6 @@
<remote-id type="github">nushell/nushell</remote-id>
</upstream>
<use>
- <flag name="extra">Install extra plugins: binaryview, tree, clipboard-cli, trash-support and others</flag>
+ <flag name="dataframe">Dataframe feature for nushell</flag>
</use>
</pkgmetadata>
diff --git a/app-shells/nushell/nushell-0.74.0.ebuild b/app-shells/nushell/nushell-0.74.0-r1.ebuild
index 51ade7423be1..40331c6ff02f 100644
--- a/app-shells/nushell/nushell-0.74.0.ebuild
+++ b/app-shells/nushell/nushell-0.74.0-r1.ebuild
@@ -577,7 +577,7 @@ SRC_URI="https://github.com/nushell/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz
LICENSE="Apache-2.0 Apache-2.0-with-LLVM-exceptions BSD-2 BSD Boost-1.0 CC0-1.0 ISC MIT MPL-2.0 Unlicense ZLIB"
SLOT="0"
KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv"
-IUSE="+extra"
+IUSE="dataframe"
DEPEND="
>=dev-libs/libgit2-0.99:=
@@ -586,11 +586,9 @@ DEPEND="
net-libs/libssh2:=
net-libs/nghttp2:=
net-misc/curl
- extra? (
- dev-db/sqlite:3=
- x11-libs/libX11
- x11-libs/libxcb
- )
+ dev-db/sqlite:3=
+ x11-libs/libX11
+ x11-libs/libxcb
"
RDEPEND="${DEPEND}"
@@ -618,7 +616,7 @@ src_configure() {
local myfeatures=(
stable
- $(usev extra)
+ $(usev dataframe)
)
cargo_src_configure