summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/commonmark/Manifest1
-rw-r--r--dev-python/commonmark/commonmark-0.8.1.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/commonmark/Manifest b/dev-python/commonmark/Manifest
index 5c0753d322e9..bfc2e44e1c68 100644
--- a/dev-python/commonmark/Manifest
+++ b/dev-python/commonmark/Manifest
@@ -1,2 +1,3 @@
DIST CommonMark-0.5.4.tar.gz 120316 BLAKE2B 47904d101d9d0e3759f82c28a4b80edfc0ed12cf0888e4915339118e496322cf0791d8a46d2edddca0d1794e82a9647cc22cbcfcc2d385a740c7c31cb8251659 SHA512 1983714a50a627f30f86af0d02dad9e52cb7b0ffce29691d0e740f587e599ead6de2412d72b895b7df772e1c81e171e56dfecaf593e611af65bd5798632a98ad
DIST CommonMark-0.7.5.tar.gz 88702 BLAKE2B fc80d9e739d27f7e5dbf539b624c2fc2e700e61b17d0335c3234fc0fa0d3738e9117a8ca29e7a6bbaa6cd0d58b112defb6e19a7efce3ca57ca25c8ce67b2d3d2 SHA512 b0e3c4fea6c99b51c541054ecfe887935c2cc517a82df86da1d9cb4914189652326ec5b543cbbcb40ec43e5e09c285c47f5304ca1907764692e659c540591bdd
+DIST commonmark-0.8.1.tar.gz 90795 BLAKE2B 718c2b1af035672d74e2c6b6f89ea0cd23f45d7b0e47b6dadeef742d772f5458e08ec5f69fd4f34df9ab2c491d9d7add4c4acc7018c4048649aa0d8244d7db91 SHA512 dbab51d45c1973a8d0906148d785fb8ddc2b52177dfe0e69fe79bef2a5eb05a5a7ab8693852f4aaa8545af19d741569d04a24f06ea65171e6e80d9f66af47fdf
diff --git a/dev-python/commonmark/commonmark-0.8.1.ebuild b/dev-python/commonmark/commonmark-0.8.1.ebuild
new file mode 100644
index 000000000000..68e34aca47df
--- /dev/null
+++ b/dev-python/commonmark/commonmark-0.8.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6,3_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python parser for the CommonMark Markdown spec"
+HOMEPAGE="https://github.com/rtfd/CommonMark-py"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ dev-python/future[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? (
+ >=dev-python/hypothesis-3.7.1[${PYTHON_USEDEP}]
+ )
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+python_test() {
+ PYTHONIOENCODING='utf8' \
+ esetup.py test
+}
+
+src_prepare() {
+ default
+ # Fix file collision with app-text/cmark, see bug #627034
+ sed -i -e "s:'cmark\( = commonmark.cmark\:main'\):'cmark.py\1:" \
+ setup.py || die
+}
+
+pkg_postinst() {
+ ewarn "/usr/bin/cmark has been renamed to /usr/bin/cmark.py due file"
+ ewarn "collision with app-text/cmark (see bug #627034)"
+}