summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-text/hunspell/files/hunspell-1.7.2-renameexes.patch (renamed from app-text/hunspell/files/hunspell-1.7.0-renameexes.patch)17
-rw-r--r--app-text/hunspell/hunspell-1.7.2-r1.ebuild81
-rw-r--r--app-text/hunspell/hunspell-1.7.2.ebuild6
3 files changed, 84 insertions, 20 deletions
diff --git a/app-text/hunspell/files/hunspell-1.7.0-renameexes.patch b/app-text/hunspell/files/hunspell-1.7.2-renameexes.patch
index c45b9cc8a154..52696b968608 100644
--- a/app-text/hunspell/files/hunspell-1.7.0-renameexes.patch
+++ b/app-text/hunspell/files/hunspell-1.7.2-renameexes.patch
@@ -14,7 +14,6 @@ https://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/app-text/hunspell/files
---
src/tools/Makefile.am | 14 +++++++-------
src/tools/chmorph.cxx | 6 +++---
- src/tools/example.cxx | 4 ++--
src/tools/munch.cxx | 4 ++--
src/tools/unmunch.cxx | 4 ++--
tests/Makefile.am | 2 +-
@@ -77,22 +76,6 @@ index 6e5add6..163186d 100644
" (convert informal Hungarian second person texts to formal third "
"person texts)\n");
exit(1);
-diff --git a/src/tools/example.cxx b/src/tools/example.cxx
-index 8213a5f..c3cc76a 100644
---- a/src/tools/example.cxx
-+++ b/src/tools/example.cxx
-@@ -48,9 +48,9 @@ int main(int argc, char** argv) {
- /* first parse the command line options */
-
- if (argc < 4) {
-- fprintf(stderr, "example (now it works with more dictionary files):\n");
-+ fprintf(stderr, "hunspell-example (now it works with more dictionary files):\n");
- fprintf(stderr,
-- "example affix_file dictionary_file(s) file_of_words_to_check\n");
-+ "hunspell-example affix_file dictionary_file(s) file_of_words_to_check\n");
- exit(1);
- }
-
diff --git a/src/tools/munch.cxx b/src/tools/munch.cxx
index 5f51fc6..c8f8beb 100644
--- a/src/tools/munch.cxx
diff --git a/app-text/hunspell/hunspell-1.7.2-r1.ebuild b/app-text/hunspell/hunspell-1.7.2-r1.ebuild
new file mode 100644
index 000000000000..97635c6a1145
--- /dev/null
+++ b/app-text/hunspell/hunspell-1.7.2-r1.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LANGS="af bg ca cs cy da de de-1901 el en eo es et fo fr ga gl he hr hu ia id is
+it kk km ku lt lv mi mk ms nb nl nn pl pt pt-BR ro ru sk sl sq sv sw tn uk zu"
+inherit autotools flag-o-matic
+
+DESCRIPTION="Spell checker, morphological analyzer library and command-line tool"
+HOMEPAGE="https://hunspell.github.io/"
+SRC_URI="https://github.com/hunspell/hunspell/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="|| ( MPL-1.1 GPL-2+ LGPL-2.1+ )"
+SLOT="0/$(ver_cut 1-2)"
+IUSE="ncurses nls readline static-libs"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+
+RDEPEND="
+ virtual/libiconv
+ ncurses? ( sys-libs/ncurses:= )
+ readline? ( sys-libs/readline:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ >=sys-devel/gettext-0.18
+"
+
+PDEPEND=""
+for lang in ${LANGS}; do
+ IUSE+=" l10n_${lang}"
+ case ${lang} in
+ de-1901) dict="de_1901" ;;
+ pt-BR) dict="pt-br" ;;
+ *) dict="${lang}" ;;
+ esac
+ PDEPEND+=" l10n_${lang}? ( app-dicts/myspell-${dict} )"
+done
+unset dict lang LANGS
+
+DOCS=( AUTHORS ChangeLog NEWS THANKS license.{hunspell,myspell} README )
+
+PATCHES=(
+ # Upstream package creates some executables which names are too generic
+ # to be placed in /usr/bin - this patch prefixes them with 'hunspell-'.
+ # It modifies a Makefile.am file, hence eautoreconf.
+ "${FILESDIR}/hunspell-1.7.2-renameexes.patch"
+
+ "${FILESDIR}/hunspell-1.7.0-tinfo.patch" # bug #692614
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ # Missing somehow...
+ [[ ${CHOST} == *-darwin* ]] && append-libs -liconv
+
+ # I wanted to put the include files in /usr/include/hunspell.
+ # You can do that, libreoffice can find them anywhere, just
+ # ping me when you do so ; -- scarabeus
+ local myeconfargs=(
+ "$(use_enable nls)"
+ "$(use_with ncurses ui)"
+ "$(use_with readline readline)"
+ "$(use_enable static-libs static)"
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ find "${ED}" -type f -name '*.la' -delete || die
+ einstalldocs
+
+ # Bug #908872
+ keepdir "/usr/share/myspell"
+}
diff --git a/app-text/hunspell/hunspell-1.7.2.ebuild b/app-text/hunspell/hunspell-1.7.2.ebuild
index e2a26ff8f926..2b5009ebd494 100644
--- a/app-text/hunspell/hunspell-1.7.2.ebuild
+++ b/app-text/hunspell/hunspell-1.7.2.ebuild
@@ -11,7 +11,7 @@ DESCRIPTION="Spell checker, morphological analyzer library and command-line tool
HOMEPAGE="https://hunspell.github.io/"
SRC_URI="https://github.com/hunspell/hunspell/releases/download/v${PV}/${P}.tar.gz"
-LICENSE="MPL-1.1 GPL-2 LGPL-2.1"
+LICENSE="|| ( MPL-1.1 GPL-2+ LGPL-2.1+ )"
SLOT="0/$(ver_cut 1-2)"
IUSE="ncurses nls readline static-libs"
KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
@@ -41,9 +41,9 @@ PATCHES=(
# Upstream package creates some executables which names are too generic
# to be placed in /usr/bin - this patch prefixes them with 'hunspell-'.
# It modifies a Makefile.am file, hence eautoreconf.
- "${FILESDIR}/${PN}-1.7.0-renameexes.patch"
+ "${FILESDIR}/hunspell-1.7.2-renameexes.patch"
- "${FILESDIR}/${PN}-1.7.0-tinfo.patch" # bug #692614
+ "${FILESDIR}/hunspell-1.7.0-tinfo.patch" # bug #692614
)
src_prepare() {