summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-wireless/ubertooth/ubertooth-2020.12.1-r1.ebuild (renamed from net-wireless/ubertooth/ubertooth-2020.12.1.ebuild)14
-rw-r--r--net-wireless/ubertooth/ubertooth-9999.ebuild14
2 files changed, 22 insertions, 6 deletions
diff --git a/net-wireless/ubertooth/ubertooth-2020.12.1.ebuild b/net-wireless/ubertooth/ubertooth-2020.12.1-r1.ebuild
index c3cfc4790455..580e009cffa1 100644
--- a/net-wireless/ubertooth/ubertooth-2020.12.1.ebuild
+++ b/net-wireless/ubertooth/ubertooth-2020.12.1-r1.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="7"
+EAPI=8
inherit cmake udev
@@ -14,7 +14,7 @@ IUSE="+bluez static-libs +ubertooth1-firmware +udev"
DEPEND="bluez? ( net-wireless/bluez:= )
>=net-libs/libbtbb-${PV}:=[static-libs?]
static-libs? ( dev-libs/libusb[static-libs] )
- virtual/libusb:1="
+ virtual/libusb:1"
RDEPEND="${DEPEND}
udev? ( virtual/udev )"
@@ -67,3 +67,11 @@ src_install() {
elog "Everyone can read from the ubertooth, but to talk to it"
elog "your user needs to be in the usb group."
}
+
+pkg_postinst() {
+ use udev && udev_reload
+}
+
+pkg_postrm() {
+ use udev && udev_reload
+}
diff --git a/net-wireless/ubertooth/ubertooth-9999.ebuild b/net-wireless/ubertooth/ubertooth-9999.ebuild
index 4a9603a7e8d4..580e009cffa1 100644
--- a/net-wireless/ubertooth/ubertooth-9999.ebuild
+++ b/net-wireless/ubertooth/ubertooth-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="7"
+EAPI=8
inherit cmake udev
@@ -14,7 +14,7 @@ IUSE="+bluez static-libs +ubertooth1-firmware +udev"
DEPEND="bluez? ( net-wireless/bluez:= )
>=net-libs/libbtbb-${PV}:=[static-libs?]
static-libs? ( dev-libs/libusb[static-libs] )
- virtual/libusb:1="
+ virtual/libusb:1"
RDEPEND="${DEPEND}
udev? ( virtual/udev )"
@@ -67,3 +67,11 @@ src_install() {
elog "Everyone can read from the ubertooth, but to talk to it"
elog "your user needs to be in the usb group."
}
+
+pkg_postinst() {
+ use udev && udev_reload
+}
+
+pkg_postrm() {
+ use udev && udev_reload
+}