summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/rich/Manifest1
-rw-r--r--dev-python/rich/rich-10.5.0.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/rich/Manifest b/dev-python/rich/Manifest
index 720656955b6f..311da1ffda86 100644
--- a/dev-python/rich/Manifest
+++ b/dev-python/rich/Manifest
@@ -1,2 +1,3 @@
DIST rich-10.3.0.tar.gz 16237609 BLAKE2B ddac8f2ed7b3b39e647179cd03cf59994729d7d82bdfad6670284a692871b79f2f6ceb86fae0d47d76401f756c122ebcb5978d241d4a95b4f3d6c54de67132a1 SHA512 91886b19c91052a7fe24fb9ae8c98a59f882e6c387036420f17a4867f581e71839b990541fcedf7831d361a9cb535f05c13e45bf5505a4d1fcdc0d0f8e8b39c8
DIST rich-10.4.0.tar.gz 16240850 BLAKE2B 76874e3efd9a8d696ba96579e1c658b1c76e71d353574cf3f9fb5d8a15810879f649d0ebfcbd1d72d9d496ce438cc08099b5d0416b932875704be2d0b4b28d0a SHA512 ecf6234ac862c1e04ab71c39763857d770c20200f5e1903a7d8e90fc1a67b5702a9eb0c67454ca48fb786a7631f60401f0a3299e82d864eca8c7afefedf21e26
+DIST rich-10.5.0.tar.gz 16242786 BLAKE2B d4d612555f9dca24b5150f5502d95bede784d7e6481e15948614de15a914d0cb3c83b64148a02db4ce8693feb1604c3729006fc0ca347eb10313aedcb795feca SHA512 c0471c0f35d3d9e5b5baf5798911073de02820a5bb5dcf42324bef2153a49a3019db44bc96b95247defe3be65f18097fc266a30bdeab153d9dda0ae38d34a79b
diff --git a/dev-python/rich/rich-10.5.0.ebuild b/dev-python/rich/rich-10.5.0.ebuild
new file mode 100644
index 000000000000..6d4831ee5fd9
--- /dev/null
+++ b/dev-python/rich/rich-10.5.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..9} )
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Python library for renrering rich text, tables, etc. to the terminal"
+HOMEPAGE="https://github.com/willmcgugan/rich"
+SRC_URI="https://github.com/willmcgugan/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/commonmark[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ optfeature "integration with HTML widgets for Jupyter" dev-python/ipywidgets
+}