summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-terms/kitty/kitty-0.31.0.ebuild7
-rw-r--r--x11-terms/kitty/kitty-9999.ebuild7
2 files changed, 10 insertions, 4 deletions
diff --git a/x11-terms/kitty/kitty-0.31.0.ebuild b/x11-terms/kitty/kitty-0.31.0.ebuild
index 9090e9ba7a22..40e4c5d20049 100644
--- a/x11-terms/kitty/kitty-0.31.0.ebuild
+++ b/x11-terms/kitty/kitty-0.31.0.ebuild
@@ -4,7 +4,8 @@
EAPI=8
PYTHON_COMPAT=( python3_{10..12} )
-inherit edo optfeature multiprocessing python-single-r1 toolchain-funcs xdg
+inherit edo go-env optfeature multiprocessing
+inherit python-single-r1 toolchain-funcs xdg
if [[ ${PV} == 9999 ]]; then
inherit git-r3
@@ -124,9 +125,11 @@ src_prepare() {
src_compile() {
tc-export CC
+ local -x PKGCONFIG_EXE=$(tc-getPKG_CONFIG)
+
+ go-env_set_compile_environment
local -x GOFLAGS="-p=$(makeopts_jobs) -v -x"
use ppc64 && [[ $(tc-endian) == big ]] || GOFLAGS+=" -buildmode=pie"
- local -x PKGCONFIG_EXE=$(tc-getPKG_CONFIG)
local conf=(
--disable-link-time-optimization
diff --git a/x11-terms/kitty/kitty-9999.ebuild b/x11-terms/kitty/kitty-9999.ebuild
index 9090e9ba7a22..40e4c5d20049 100644
--- a/x11-terms/kitty/kitty-9999.ebuild
+++ b/x11-terms/kitty/kitty-9999.ebuild
@@ -4,7 +4,8 @@
EAPI=8
PYTHON_COMPAT=( python3_{10..12} )
-inherit edo optfeature multiprocessing python-single-r1 toolchain-funcs xdg
+inherit edo go-env optfeature multiprocessing
+inherit python-single-r1 toolchain-funcs xdg
if [[ ${PV} == 9999 ]]; then
inherit git-r3
@@ -124,9 +125,11 @@ src_prepare() {
src_compile() {
tc-export CC
+ local -x PKGCONFIG_EXE=$(tc-getPKG_CONFIG)
+
+ go-env_set_compile_environment
local -x GOFLAGS="-p=$(makeopts_jobs) -v -x"
use ppc64 && [[ $(tc-endian) == big ]] || GOFLAGS+=" -buildmode=pie"
- local -x PKGCONFIG_EXE=$(tc-getPKG_CONFIG)
local conf=(
--disable-link-time-optimization