summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-perl/Format-Human-Bytes/Format-Human-Bytes-0.60.0-r2.ebuild25
-rw-r--r--dev-perl/Format-Human-Bytes/files/Format-Human-Bytes-0.06-no-dot-inc.patch21
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-perl/Format-Human-Bytes/Format-Human-Bytes-0.60.0-r2.ebuild b/dev-perl/Format-Human-Bytes/Format-Human-Bytes-0.60.0-r2.ebuild
new file mode 100644
index 000000000000..7398d917c3d6
--- /dev/null
+++ b/dev-perl/Format-Human-Bytes/Format-Human-Bytes-0.60.0-r2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=SEWI
+DIST_VERSION=0.06
+inherit perl-module
+
+DESCRIPTION="Format a bytecount and make it human readable"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ >=virtual/perl-ExtUtils-MakeMaker-6.420.0
+ test? (
+ virtual/perl-Test-Simple
+ )
+"
+PATCHES=(
+ "${FILESDIR}/${PN}-0.06-no-dot-inc.patch"
+)
diff --git a/dev-perl/Format-Human-Bytes/files/Format-Human-Bytes-0.06-no-dot-inc.patch b/dev-perl/Format-Human-Bytes/files/Format-Human-Bytes-0.06-no-dot-inc.patch
new file mode 100644
index 000000000000..af43083966c3
--- /dev/null
+++ b/dev-perl/Format-Human-Bytes/files/Format-Human-Bytes-0.06-no-dot-inc.patch
@@ -0,0 +1,21 @@
+From a1a1935d7951e5baa890dc1150d3112ed79860ba Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentnl@gentoo.org>
+Date: Fri, 18 Sep 2020 01:32:16 +1200
+Subject: Ensure '.' in @INC on Perl 5.26+
+
+---
+ Makefile.PL | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/Makefile.PL b/Makefile.PL
+index ee699b3..b5fad9c 100644
+--- a/Makefile.PL
++++ b/Makefile.PL
+@@ -1,3 +1,4 @@
++use lib '.';
+ use inc::Module::Install;
+
+ name 'Format-Human-Bytes';
+--
+2.28.0
+