summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/exceptiongroup/Manifest1
-rw-r--r--dev-python/exceptiongroup/exceptiongroup-1.0.2.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/exceptiongroup/Manifest b/dev-python/exceptiongroup/Manifest
index c3ac5386c6cb..c113f376cf38 100644
--- a/dev-python/exceptiongroup/Manifest
+++ b/dev-python/exceptiongroup/Manifest
@@ -1,2 +1,3 @@
DIST exceptiongroup-1.0.0.gh.tar.gz 19766 BLAKE2B 2c4aa2c7c096b91971872b2236fad211a1bd7cb8ae921f5a0255b5a534eefdb5033bbca4c562ff7045acf30e13371a38d52851749cd5bca4df6adfe359a43012 SHA512 e2e05066c0c7664bb36696737c0c33abd811637c5f0ae7e70a20525283d4db4667fa814b15cb6b21165416ae1a0c47f22250a2ed9be4be99b6237e0c1b45fdd4
DIST exceptiongroup-1.0.1.gh.tar.gz 20267 BLAKE2B 1438e88a51034acd8b032339097640862da323dc46aaab4f64e53a3e8c3ce8a7bbda16cc72eff9c4f3ac44d8c239b9e51d3561781bbd0ed88fe9e1db78e95c2b SHA512 79a678b6d3d152334ff593d15047e4b4c8714d50bd667ff2c878617512fe78b0c1d9df113db221d9ac7ea1e4522427747d85e26ae2d46b16f15538e1a638cc38
+DIST exceptiongroup-1.0.2.gh.tar.gz 20586 BLAKE2B 09b1b7bee8f1e379c8ef48d9c8202efd7bc530029c5e2a7b91f0204e99429fade8cfa7427e2a88b52747b3308c0a03b193397b3c35c50ea7a9741c15d6f591f6 SHA512 c93a9b85649d662ae63d8396d262eaaff90b068e60f85e747d2538380a262afd54b16bfb0bae49c3909a39950574b9d777120c86e91344259700224480782759
diff --git a/dev-python/exceptiongroup/exceptiongroup-1.0.2.ebuild b/dev-python/exceptiongroup/exceptiongroup-1.0.2.ebuild
new file mode 100644
index 000000000000..b848cb3eea31
--- /dev/null
+++ b/dev-python/exceptiongroup/exceptiongroup-1.0.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit_scm
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+MY_P=${P/_}
+DESCRIPTION="Backport of PEP 654 (exception groups)"
+HOMEPAGE="
+ https://github.com/agronholm/exceptiongroup/
+ https://pypi.org/project/exceptiongroup/
+"
+SRC_URI="
+ https://github.com/agronholm/exceptiongroup/archive/${PV/_}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT PSF-2.4"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV/_}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}