summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www-apps/gitea/Manifest1
-rw-r--r--www-apps/gitea/files/gitea.service-r334
-rw-r--r--www-apps/gitea/gitea-1.20.6.ebuild131
3 files changed, 0 insertions, 166 deletions
diff --git a/www-apps/gitea/Manifest b/www-apps/gitea/Manifest
index 3ebb0f9ea093..5c096f065b7b 100644
--- a/www-apps/gitea/Manifest
+++ b/www-apps/gitea/Manifest
@@ -1,3 +1,2 @@
-DIST gitea-1.20.6.tar.gz 50473256 BLAKE2B 0b26e38815dc1bf16c6f50c0b4cd7e6c3c3e0900056beda6177cb7fd1df1378e89a6ca47228f3fef2f6176eb5054d1bfb999ba1a1314a5915dbbff62f0f1365a SHA512 fb0a979bdaaec25512f70cbcb1907d5e649eff2d0795a6bb5fe9e582ada1f132ca649dd594ccd24051fa6e2e0fd3b94effc66475ab2f9faeb03cebd4c657336a
DIST gitea-1.21.2.tar.gz 53795805 BLAKE2B ee85aae28325df59aa7fefcda5e3ec4216f79e115972fcbea543b189c6f8fe2bb2f7d23f27cd2418c7f50e474177398e4cd925474ca5d68fe3bab64a2cf785b7 SHA512 809254dfe420fb97697855d2aa815344b56d316edaec140598526fc7728275ca9a10179093b8d036cce0947684234a0aa2fa7febdd1bbdf7f831a249cc16ba4a
DIST gitea-1.21.3.tar.gz 53775315 BLAKE2B 0baae678e3ad75129f753d0e1eadf83b06008da5041f6859f985facc78f223284f17cad0e8858c9c8a7d6ca34042c7cb19f69fa30a560170a60b3548bdef8f6b SHA512 f55336d4067d9403c5556a8a641ca805c13e3c7dbc60a684329cb9f3a886c0ebb10a3318dc9c4c3251e1bd0bcc0821fe40575d9ada1779012a850d592acdabd1
diff --git a/www-apps/gitea/files/gitea.service-r3 b/www-apps/gitea/files/gitea.service-r3
deleted file mode 100644
index 0867ba637824..000000000000
--- a/www-apps/gitea/files/gitea.service-r3
+++ /dev/null
@@ -1,34 +0,0 @@
-[Unit]
-Description=Gitea service
-Documentation=https://docs.gitea.io/
-
-AssertPathIsDirectory=/var/lib/gitea
-AssertPathIsReadWrite=/var/lib/gitea
-
-After=network.target
-Requires=network.target
-After=mysqld.service
-After=postgresql-9.5.service
-After=postgresql-9.6.service
-After=postgresql-10.service
-After=postgresql-11.service
-After=postgresql-12.service
-After=postgresql-13.service
-After=postgresql-14.service
-After=memcached.service
-After=redis.service
-
-[Service]
-User=git
-Group=git
-
-Environment="GITEA_WORK_DIR=/var/lib/gitea" "GITEA_CUSTOM=/var/lib/gitea/custom"
-WorkingDirectory=/var/lib/gitea
-ExecStart=/usr/bin/gitea web --config /etc/gitea/app.ini
-
-Restart=always
-PrivateTmp=true
-Nice=5
-
-[Install]
-WantedBy=multi-user.target
diff --git a/www-apps/gitea/gitea-1.20.6.ebuild b/www-apps/gitea/gitea-1.20.6.ebuild
deleted file mode 100644
index 528d3b3a10f7..000000000000
--- a/www-apps/gitea/gitea-1.20.6.ebuild
+++ /dev/null
@@ -1,131 +0,0 @@
-# Copyright 2016-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit fcaps go-module tmpfiles systemd flag-o-matic user-info
-
-DESCRIPTION="A painless self-hosted Git service"
-HOMEPAGE="https://gitea.com https://github.com/go-gitea/gitea"
-
-if [[ ${PV} == *9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/go-gitea/gitea.git"
-else
- SRC_URI="https://github.com/go-gitea/gitea/releases/download/v${PV}/gitea-src-${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="amd64 ~arm ~arm64 ~riscv ~x86"
-fi
-
-S="${WORKDIR}/${PN}-src-${PV}"
-
-LICENSE="Apache-2.0 BSD BSD-2 ISC MIT MPL-2.0"
-SLOT="0"
-IUSE="+acct pam sqlite pie"
-
-DEPEND="
- acct? (
- acct-group/git
- acct-user/git[gitea] )
- pam? ( sys-libs/pam )"
-RDEPEND="${DEPEND}
- dev-vcs/git"
-
-DOCS=(
- custom/conf/app.example.ini CONTRIBUTING.md README.md
-)
-FILECAPS=(
- -m 711 cap_net_bind_service+ep usr/bin/gitea
-)
-
-RESTRICT="test"
-
-src_prepare() {
- default
-
- sed -i -e "s#^MODE = console#MODE = file#" custom/conf/app.example.ini || die
- if use sqlite ; then
- sed -i -e "s#^DB_TYPE = .*#DB_TYPE = sqlite3#" custom/conf/app.example.ini || die
- fi
-}
-
-src_configure() {
- # bug 832756 - PIE build issues
- filter-flags -fPIE
- filter-ldflags -fPIE -pie
-}
-
-src_compile() {
- local gitea_tags=(
- bindata
- $(usev pam)
- $(usex sqlite 'sqlite sqlite_unlock_notify' '')
- )
- local gitea_settings=(
- "-X code.gitea.io/gitea/modules/setting.CustomConf=${EPREFIX}/etc/gitea/app.ini"
- "-X code.gitea.io/gitea/modules/setting.CustomPath=${EPREFIX}/var/lib/gitea/custom"
- "-X code.gitea.io/gitea/modules/setting.AppWorkPath=${EPREFIX}/var/lib/gitea"
- )
- local makeenv=(
- DRONE_TAG="${PV}"
- LDFLAGS="-extldflags \"${LDFLAGS}\" ${gitea_settings[*]}"
- TAGS="${gitea_tags[*]}"
- )
-
- GOFLAGS=""
- if use pie ; then
- GOFLAGS+="-buildmode=pie"
- fi
-
- env "${makeenv[@]}" emake EXTRA_GOFLAGS="${GOFLAGS}" backend
-}
-
-src_install() {
- dobin gitea
-
- einstalldocs
-
- newconfd "${FILESDIR}/gitea.confd-r1" gitea
- newinitd "${FILESDIR}/gitea.initd-r3" gitea
- newtmpfiles - gitea.conf <<-EOF
- d /run/gitea 0755 git git
- EOF
- systemd_newunit "${FILESDIR}"/gitea.service-r3 gitea.service
-
- insinto /etc/gitea
- newins custom/conf/app.example.ini app.ini
- if use acct; then
- fowners root:git /etc/gitea/{,app.ini}
- fperms g+w,o-rwx /etc/gitea/{,app.ini}
-
- diropts -m0750 -o git -g git
- keepdir /var/lib/gitea /var/lib/gitea/custom /var/lib/gitea/data
- keepdir /var/log/gitea
- fi
-}
-
-pkg_postinst() {
- fcaps_pkg_postinst
-
- # It is not guaranteed that the git user and group always exist (due to the acct USE Flag),
- # but for convenience, the tmpfile uses the git user and group by default.
- # To avoid installation errors, a condition needs to be added here:
- # if there is no git user or group, the installation of tmpfile will be skipped
- # and the user will be notified to handle it by themselves.
- if egetent passwd git &>/dev/null && \
- egetent group git &>/dev/null; then
- tmpfiles_process gitea.conf
- else
- eerror "Unable to install the tmpfile for gitea due to the git user or group is missing,"
- eerror "please install tmpfile manually or rebuild this package with USE flag 'acct'."
- eerror "You can simply copy the default tmpfile from '/usr/lib/tmpfiles.d/gitea.conf'"
- eerror "to higher priority path '/etc/tmpfiles.d/gitea.conf', and correct it with"
- eerror "the right User and Group value (see tmpfiles.d(5) for details), then execute:"
- eerror " # systemd-tmpfiles --create /etc/tmpfiles.d/gitea.conf"
- eerror "to install it."
- fi
-
- ewarn "The default JWT signing algorithm changed in 1.15.0 from HS256 (symmetric) to"
- ewarn "RS256 (asymmetric). Gitea OAuth2 tokens (and potentially client secrets) will"
- ewarn "need to be regenerated unless you change your JWT_SIGNING_ALGORITHM back to HS256."
- ewarn "For other breaking changes, see <https://github.com/go-gitea/gitea/releases/tag/v1.15.0>."
-}