summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www-servers/gatling/Manifest1
-rw-r--r--www-servers/gatling/gatling-0.16.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/www-servers/gatling/Manifest b/www-servers/gatling/Manifest
index ea5623b01656..59942cd426c0 100644
--- a/www-servers/gatling/Manifest
+++ b/www-servers/gatling/Manifest
@@ -1 +1,2 @@
DIST gatling-0.15.tar.xz 121804 BLAKE2B 7df5f6d4fc823e8a1252bacca2b57d0848dd3a920216d1d3185d5f471f786eee1eb36396114b367660ead816bd4ee6c734099bbb9bdb5ffbd5b70a59e0fb0667 SHA512 b76d220a0644f1e6e7ea966a4eff409964c564fc4a31c4efdb764e5f7b5857bc58c26bc31e860fe35df932cbd60fb2b0f4f21c75cb5aa56427e8a2a453684716
+DIST gatling-0.16.tar.xz 126844 BLAKE2B 33dd2e93833b216ffadae4dbd5650af87b23ed5d62caf181d8005acb4dce889b86d1afb711676377ba2b7c4fe08b8f2350a32965cf6292a268281b28c4310c27 SHA512 9446ea0ae862509b1a892e5bdef14d3a2320c3c3e846362b4679c0834aa906ab5b16ef54e4a7c8e7ee839d30317436dd411e891e3105035a9ee31b0facc0b8c1
diff --git a/www-servers/gatling/gatling-0.16.ebuild b/www-servers/gatling/gatling-0.16.ebuild
new file mode 100644
index 000000000000..c1b0e8bf0abe
--- /dev/null
+++ b/www-servers/gatling/gatling-0.16.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit eutils toolchain-funcs user
+
+DESCRIPTION="High performance web server"
+HOMEPAGE="https://www.fefe.de/gatling/"
+SRC_URI="https://www.fefe.de/gatling/${P}.tar.xz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="libressl ssl diet"
+REQUIRED_USE="ssl? ( !diet )"
+
+DEPEND=">=dev-libs/libowfat-0.32-r2[diet=]
+ diet? ( dev-libs/dietlibc )
+ ssl? (
+ !libressl? ( dev-libs/openssl:0 )
+ libressl? ( dev-libs/libressl )
+ )"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.13-compile.patch"
+ "${FILESDIR}/${PN}-0.15-ar.patch"
+)
+
+src_prepare() {
+ default
+ rm Makefile # leaves us with GNUmakefile
+}
+
+src_compile() {
+ local DIET=
+ use diet && DIET='/usr/bin/diet'
+
+ local targets='gatling'
+ use ssl && targets+=' tlsgatling'
+
+ emake DIET="${DIET}" CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS} -I${ROOT}/usr/include/libowfat" \
+ LDFLAGS="${LDFLAGS}" prefix=/usr ${targets}
+}
+
+src_install() {
+ doman gatling.1
+
+ newconfd "${FILESDIR}/gatling.confd" gatling
+ newinitd "${FILESDIR}/gatling.initd-3" gatling
+ dodoc README.{ftp,http}
+
+ dobin gatling
+ use ssl && {
+ dodoc README.tls
+ dobin tlsgatling
+ }
+}
+
+pkg_setup() {
+ ebegin "Creating gatling user and group"
+ enewgroup gatling
+ enewuser ${PN} -1 -1 /var/www/localhost ${PN}
+}