summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-emacs/doom-modeline/doom-modeline-3.3.2.ebuild10
1 files changed, 2 insertions, 8 deletions
diff --git a/app-emacs/doom-modeline/doom-modeline-3.3.2.ebuild b/app-emacs/doom-modeline/doom-modeline-3.3.2.ebuild
index 3c29bcf81e15..6740287569c1 100644
--- a/app-emacs/doom-modeline/doom-modeline-3.3.2.ebuild
+++ b/app-emacs/doom-modeline/doom-modeline-3.3.2.ebuild
@@ -25,15 +25,9 @@ RDEPEND="
"
BDEPEND="${RDEPEND}"
+elisp-enable-tests ert test
+
src_compile() {
elisp_src_compile
elisp-make-autoload-file
}
-
-src_test() {
- ${EMACS} ${EMACSFLAGS} ${BYTECOMPFLAGS} \
- -L . -L test \
- -l test/${PN}-core-test.el \
- -l test/${PN}-env-test.el \
- -f ert-run-tests-batch-and-exit || die "tests failed"
-}