summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-libs/dlib/Manifest3
-rw-r--r--sci-libs/dlib/dlib-18.15.ebuild44
-rw-r--r--sci-libs/dlib/dlib-18.7.ebuild44
-rw-r--r--sci-libs/dlib/dlib-19.4.ebuild69
-rw-r--r--sci-libs/dlib/files/dlib-17.48-makefile-test.patch35
-rw-r--r--sci-libs/dlib/metadata.xml9
6 files changed, 77 insertions, 127 deletions
diff --git a/sci-libs/dlib/Manifest b/sci-libs/dlib/Manifest
index a3a80ea6ce46..3754a6afb311 100644
--- a/sci-libs/dlib/Manifest
+++ b/sci-libs/dlib/Manifest
@@ -1,2 +1 @@
-DIST dlib-18.15.tar.bz2 7088379 SHA256 e2b790222d625c863d43b3b7dec86a826b504fc10b4b69b242f59a82e9dda16c SHA512 16f42fcdc63214b72328204fca2f7e3d36e18a67fd0f4b97acd9fa5046d7bf41f56ab4209a7a92c54896746b72f6f925ae07ca57ea89982c7e26c0a4ee4b693c WHIRLPOOL a15e181de3e43b800932ce338312ed875788c561bb7ed0ad689882b892f72da891b2a8547763472101e835b652322ab6ab301c6cbf117e2442156320f8603716
-DIST dlib-18.7.tar.bz2 5676950 SHA256 e3d801905288683eee245ff205081343eb79d31d5bb50e42f0293fe5b4a3697e SHA512 20f746a430bd3327f6329d9b198da67d66880f63185b5cd000bcd61a203fad6d775b77c923c92186c122ecd4d4e84f5463e4f81da86b4158d9cc24697cb54365 WHIRLPOOL f7c11fd295f791ce9e2b40c5121a20b3d14ced4d574dc1401a3eb4b2e646fae0f5b01b5a4b4ed6532dea9bcf1c0657147ae32f1e4e9c367fe357ec28287cbec3
+DIST dlib-19.4.tar.gz 7226923 SHA256 2bed9669f1a5c436579498d0806b27a9b60c42a975a9b6e67b594b40f58b1a88 SHA512 23bf80353f9b6ce07b6a3a7df05016705645c18bcf2b3ead567935008ea12c9f6dc0722d9bbacc009bd26f78eb43c1cbecf776bfed5a3445c1f2e8e208f201e2 WHIRLPOOL 300670d12b306e224fce6d7f22d79690f543876f78d30064ab2f9782a3a79a031a6b048863a5a2b21f27eb2538b9ab42f9d00dc88f144129fa591b4b1387c367
diff --git a/sci-libs/dlib/dlib-18.15.ebuild b/sci-libs/dlib/dlib-18.15.ebuild
deleted file mode 100644
index 23ef281fa00c..000000000000
--- a/sci-libs/dlib/dlib-18.15.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit eutils toolchain-funcs
-
-DESCRIPTION="Numerical and networking C++ library"
-HOMEPAGE="http://dlib.net/"
-SRC_URI="mirror://sourceforge/dclib/${P}.tar.bz2"
-
-LICENSE="Boost-1.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="blas doc examples jpeg lapack png test X"
-
-RDEPEND="
- blas? ( virtual/blas )
- jpeg? ( virtual/jpeg:0= )
- lapack? ( virtual/lapack )
- png? ( media-libs/libpng:0= )
- X? ( x11-libs/libX11 )"
-DEPEND="test? ( ${RDEPEND} )"
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-17.48-makefile-test.patch
-}
-
-src_test() {
- cd dlib/test || die
- emake CXX="$(tc-getCXX)" CXXFLAGS="${CXXFLAGS}"
- ./dtest --runall || die
-}
-
-src_install() {
- dodoc dlib/README.txt
- rm -r dlib/{README,LICENSE}.txt dlib/test || die
- doheader -r dlib
- use doc && dohtml -r docs/*
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r examples
- fi
-}
diff --git a/sci-libs/dlib/dlib-18.7.ebuild b/sci-libs/dlib/dlib-18.7.ebuild
deleted file mode 100644
index 2e1697899c57..000000000000
--- a/sci-libs/dlib/dlib-18.7.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit eutils toolchain-funcs
-
-DESCRIPTION="Numerical and networking C++ library"
-HOMEPAGE="http://dlib.net/"
-SRC_URI="mirror://sourceforge/dclib/${P}.tar.bz2"
-
-LICENSE="Boost-1.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="blas doc examples jpeg lapack png test X"
-
-RDEPEND="
- blas? ( virtual/blas )
- jpeg? ( virtual/jpeg:0= )
- lapack? ( virtual/lapack )
- png? ( media-libs/libpng:0= )
- X? ( x11-libs/libX11 )"
-DEPEND="test? ( ${RDEPEND} )"
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-17.48-makefile-test.patch
-}
-
-src_test() {
- cd dlib/test || die
- emake CXX="$(tc-getCXX)" CXXFLAGS="${CXXFLAGS}"
- ./test --runall || die
-}
-
-src_install() {
- dodoc dlib/README.txt
- rm -r dlib/{README,LICENSE}.txt dlib/test || die
- doheader -r dlib
- use doc && dohtml -r docs/*
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r examples
- fi
-}
diff --git a/sci-libs/dlib/dlib-19.4.ebuild b/sci-libs/dlib/dlib-19.4.ebuild
new file mode 100644
index 000000000000..9d44e7177a75
--- /dev/null
+++ b/sci-libs/dlib/dlib-19.4.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="Numerical and networking C++ library"
+HOMEPAGE="http://dlib.net/"
+SRC_URI="https://github.com/davisking/dlib/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Boost-1.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="cblas debug cuda examples gif jpeg lapack mkl png
+ sqlite static-libs test X"
+
+# doc needs a bunch of deps not in portage
+
+RDEPEND="
+ cblas? ( virtual/cblas:= )
+ cuda? ( >=dev-util/nvidia-cuda-toolkit-7 )
+ jpeg? ( virtual/jpeg:0= )
+ lapack? ( virtual/lapack:= )
+ mkl? ( sci-libs/mkl )
+ png? ( media-libs/libpng:0= )
+ sqlite? ( dev-db/sqlite:3= )
+ X? ( x11-libs/libX11 )
+"
+DEPEND="test? ( ${RDEPEND} )"
+
+src_prepare() {
+ cmake-utils_src_prepare
+ sed -i -e '/LICENSE.txt/d' dlib/CMakeLists.txt || die
+}
+src_configure() {
+ local mycmakeargs=(
+ -DLIB_INSTALL_DIR="$(get_libdir)"
+ -DDLIB_ENABLE_ASSERTS="$(usex debug)"
+ -DDLIB_ENABLE_STACK_TRACE="$(usex debug)"
+ -DDLIB_GIF_SUPPORT="$(usex gif)"
+ -DDLIB_JPEG_SUPPORT="$(usex jpeg)"
+ -DDLIB_PNG_SUPPORT="$(usex png)"
+ -DDLIB_LINK_WITH_SQLITE3="$(usex sqlite)"
+ -DDLIB_NO_GUI_SUPPORT="$(usex X OFF ON)"
+ -DDLIB_USE_BLAS="$(usex cblas)"
+ -DDLIB_USE_CUDA="$(usex cuda)"
+ -DDLIB_USE_LAPACK="$(usex lapack)"
+ )
+ cmake-utils_src_configure
+}
+
+src_test() {
+ mkdir "${BUILD_DIR}"/dlib/test || die
+ pushd "${BUILD_DIR}"/dlib/test > /dev/null || die
+ cmake "${S}"/dlib/test && emake
+ ./dtest --runall || die
+ popd > /dev/null || die
+}
+
+src_install() {
+ cmake-utils_src_install
+ dodoc docs/README.txt
+ use static-libs || rm -f "${ED}"/usr/$(get_libdir)/*.a
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}
+ fi
+}
diff --git a/sci-libs/dlib/files/dlib-17.48-makefile-test.patch b/sci-libs/dlib/files/dlib-17.48-makefile-test.patch
deleted file mode 100644
index 81aed4431954..000000000000
--- a/sci-libs/dlib/files/dlib-17.48-makefile-test.patch
+++ /dev/null
@@ -1,35 +0,0 @@
---- dlib/test/makefile.orig 2012-12-10 23:56:00.000000000 +0000
-+++ dlib/test/makefile 2012-12-10 23:59:07.000000000 +0000
-@@ -5,14 +5,15 @@
- TARGET = test
-
- # these are the compile time flags passed to gcc
--CFLAGS = -ggdb -DDEBUG -DDLIB_NO_GUI_SUPPORT -I ../.. -Wall
-+CPPFLAGS := -DDEBUG -DDLIB_NO_GUI_SUPPORT -I../..
-+CXXFLAGS := -ggdb -Wall
-
- # These are the link time flags passed to gcc
- LFLAGS = -lpthread -lnsl
-
- # The name of the compiler. If you only have one version of
- # gcc installed then you probably want to change this to just g++
--CC = nice g++
-+CXX := nice g++
-
- ####################################################
- ####################################################
-@@ -146,13 +147,9 @@
-
- $(TARGET): $(OBJ)
- @echo Linking $@
-- @$(CC) $(OBJ) $(LFLAGS) -o $@
-+ @$(CXX) $(LDFLAGS) $(OBJ) $(LFLAGS) -o $@
- @echo Build Complete
-
--.cpp.o: $<
-- @echo Compiling $<
-- @$(CC) -c $(CFLAGS) $< -o $@
--
- clean:
- @rm -f $(OBJ) $(TARGET)
- @echo All object files and binaries removed
diff --git a/sci-libs/dlib/metadata.xml b/sci-libs/dlib/metadata.xml
index 0ac2080f0f17..3d2eccafb59b 100644
--- a/sci-libs/dlib/metadata.xml
+++ b/sci-libs/dlib/metadata.xml
@@ -10,8 +10,13 @@
networking, threads, graphical interfaces, data structures, linear
algebra, machine learning, XML and text parsing, numerical
optimization, Bayesian nets, and numerous other tasks.
-</longdescription>
+ </longdescription>
+ <use>
+ <flag name="cblas">Build with CBLAS <pkg>virtual/cblas</pkg></flag>
+ <flag name="cuda">Enable support for CUDA for GPU (cuDNN)</flag>
+ <flag name="mkl">Enable support for Intel FFT <pkg>sci-libs/mkl</pkg></flag>
+ </use>
<upstream>
- <remote-id type="sourceforge">dclib</remote-id>
+ <remote-id type="github">davisking/dlib</remote-id>
</upstream>
</pkgmetadata>