summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-doc/python-docs/Manifest1
-rw-r--r--app-doc/python-docs/python-docs-3.10.14.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/app-doc/python-docs/Manifest b/app-doc/python-docs/Manifest
index 46f1d5fe45cf..3e1f67ea6f02 100644
--- a/app-doc/python-docs/Manifest
+++ b/app-doc/python-docs/Manifest
@@ -1,5 +1,6 @@
DIST python-2.7.18-docs-html.tar.bz2 4634932 BLAKE2B c48e2dede15d8186231acf65709641e0844c42e924262d6ee21a55e515aaf4d023bf394681bab780ab83998de9f409685e2d5870506810432145acc6422eff9d SHA512 db39390577ec86f13c9b6b57c01cba36fe9fd89092a773dc94f1a6a19d912759d097c4d80e765d3657b572abc731c1da9e7b4cd4c38065cd444606b906744abe
DIST python-3.10.13-docs-html.tar.bz2 7429989 BLAKE2B 7ddd11dbc4012cebf2f5980653b761ee35b986b75d96d582800f84e4c371aee4b82fcc2001c744e7f14991e766b0930a9ef4cb46869544e0aa403e513c4bd418 SHA512 be2cb6a2ece7849b1c259e9d86b7cf5e2a91c30a976b155c4055fc229d35a1762a90321a6227e890b6d5be51ab3377b9059b9662eed683933ec676fc2dc5f9a9
+DIST python-3.10.14-docs-html.tar.bz2 7441459 BLAKE2B 484508fc2610fdffe6bd7370afe27a0a4d7672fd4d528a726ec5b03ca7084e88d057326ccb3e41d79b6ab105211314d3b3e4c11acab40d4ce8dab725b80be5d7 SHA512 4232cca2c31a87362d3c0bde27f029eb4f475be0eab4eeeaeffa70825f2d40c91d80e88feb44408c2014ee5e012554442f0c1d394f110b9e49209e7534cce600
DIST python-3.11.7-docs-html.tar.bz2 7855621 BLAKE2B da23f6fc60a47b0796de1b18190922110383ec6185a76e074608f4c1f18c38b89deefd31f63bcf6ce6f82f1731ef68177b209cc1f6c7145f391d48e8fc79ce6d SHA512 6fe0e7d86af549b0f8c59dd84d90f403ed4e5adee61289fe194d788305059ad492265cdb7b8185030f4f872eb40b2311d6a9250a7343edafa75d318d1dfcf864
DIST python-3.11.8-docs-html.tar.bz2 7964849 BLAKE2B 76d5997ddec028f1123345a713f5d50809e0ea53aca31a6ac9ab2e15b87538abf5a4662da2a1c2404bf2ddd92cca4d5db5753fadb7cf3f83a7256d7f22c138bc SHA512 d56f139977feb14512fe32ff2ed4048ce7bea361822f4d868ec34ca9decd70749153b80c969d4ff4940ce1a2b1adf452204aa91a661e6a37df6329c7ccc35bac
DIST python-3.12.1-docs-html.tar.bz2 8189226 BLAKE2B 6382c00670872615910e3c645f24872b6417227b172b18fc3f8b3dd3fadb1444056ed0c07088b21fe6ae91f71c7d295aac8031cda48e2be8e39bf8c4b366ea18 SHA512 605085ebdac199dfcaf39e909c69cea0c2247aa90dface5c8192312dc2f228ee4ece61eb905e9557e7d1786d338c318eee6a780f6398f07ba4db7d50c4e84bb2
diff --git a/app-doc/python-docs/python-docs-3.10.14.ebuild b/app-doc/python-docs/python-docs-3.10.14.ebuild
new file mode 100644
index 000000000000..8483ad559ab4
--- /dev/null
+++ b/app-doc/python-docs/python-docs-3.10.14.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="HTML documentation for Python"
+HOMEPAGE="https://www.python.org/doc/"
+SRC_URI="https://www.python.org/ftp/python/doc/${PV}/python-${PV}-docs-html.tar.bz2"
+S="${WORKDIR}/python-${PV}-docs-html"
+
+LICENSE="PSF-2"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+src_install() {
+ rm -r _sources || die
+ docinto html
+ dodoc -r .
+
+ newenvd - 60python-docs-${SLOT} <<-EOF
+ PYTHONDOCS_${SLOT//./_}="${EPREFIX}/usr/share/doc/${PF}/html/library"
+ EOF
+}