summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/pytest-django/Manifest2
-rw-r--r--dev-python/pytest-django/pytest-django-2.9.1.ebuild37
-rw-r--r--dev-python/pytest-django/pytest-django-3.4.4.ebuild26
3 files changed, 27 insertions, 38 deletions
diff --git a/dev-python/pytest-django/Manifest b/dev-python/pytest-django/Manifest
index 1f1e5daba4c0..27f317f75048 100644
--- a/dev-python/pytest-django/Manifest
+++ b/dev-python/pytest-django/Manifest
@@ -1 +1 @@
-DIST pytest-django-2.9.1.tar.gz 50570 BLAKE2B f709ba00e16686cc2c7b3db168e775e8fcbebdb8ed732882d53c6c377d957af220b63dbe48120850de0773021f448270d855635336d08b6914edaa8c877c18bd SHA512 0e50f45a0cfefb6fa74f7d60d5173e3e8dac49ac669c9c88e46d27a01cff5c4a255d6f707863406b6f8707e25e9bea3408cbffbb75a2680fee365b9c9167d468
+DIST pytest-django-3.4.4.tar.gz 66962 BLAKE2B a989009eccab4bbd96e32ed1b6b5d03ca8105026c6d9219ea09f6b33fe2087a30d9042e2cd5a313196ed67cc1c5dc940d04fe981dda0da4f25cf16a43e88471a SHA512 a851b27e9abc4829a47abb5da40cbd69fea5c48b05c81f88910d4345696c6d01f78e07ac489cec7cfb5724dd8432891ff9260dc585e720d758491906812661df
diff --git a/dev-python/pytest-django/pytest-django-2.9.1.ebuild b/dev-python/pytest-django/pytest-django-2.9.1.ebuild
deleted file mode 100644
index ecfe25826b50..000000000000
--- a/dev-python/pytest-django/pytest-django-2.9.1.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="A Django plugin for py.test"
-HOMEPAGE="https://pypi.org/project/pytest-django/ https://pytest-django.readthedocs.org https://github.com/pytest-dev/pytest-django"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-SLOT="0"
-
-RDEPEND=""
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- >=dev-python/setuptools_scm-1.8.0[${PYTHON_USEDEP}]
-"
-
-# https://github.com/pytest-dev/pytest-django/issues/290
-RESTRICT=test
-
-src_prepare() {
- sed \
- -e '/setuptools_scm/s:==1.8.0::g' \
- -i setup.py || die
- distutils-r1_src_prepare
-}
-
-python_test() {
- PYTEST_PLUGINS=${PN/-/_} \
- py.test --ds=pytest_django_test.settings_sqlite_file --strict -r fEsxXw || die
-}
diff --git a/dev-python/pytest-django/pytest-django-3.4.4.ebuild b/dev-python/pytest-django/pytest-django-3.4.4.ebuild
new file mode 100644
index 000000000000..8bf3d8318118
--- /dev/null
+++ b/dev-python/pytest-django/pytest-django-3.4.4.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6,3_7} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A Django plugin for py.test"
+HOMEPAGE="https://pypi.org/project/pytest-django/ https://pytest-django.readthedocs.org https://github.com/pytest-dev/pytest-django"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+SLOT="0"
+
+RDEPEND="
+ >=dev-python/pytest-3.6[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ >=dev-python/setuptools_scm-1.11.1[${PYTHON_USEDEP}]
+"
+
+# not all test dependencies are packaged and this package isn't worth it.
+RESTRICT="test"