summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-5.16.3.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index 5288e83e011b..5e300ccbc962 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -7,3 +7,4 @@ DIST hypothesis-python-5.15.1.tar.gz 9010924 BLAKE2B a00ebf581781e47fd85fa9d5044
DIST hypothesis-python-5.16.0.tar.gz 9011031 BLAKE2B 65659f72094ac7fcc82c7e5a8b88c0156345530742412f13398dc72ce50d2466fa9b04b5cf4a79e87916aae770f2a89aa880d1d238890c7f8c8483c4c5068bcb SHA512 66366c172aaed84f1fb5fe0cef4e0fccfa4f65c31a94d52cf3a49b44b535f8366e71974f2aaa7b39d1d1b4171fd92cbfe4bbbac8ec4b9c4ccd2b0e5d15976d26
DIST hypothesis-python-5.16.1.tar.gz 9011388 BLAKE2B 9d80cd296475846404ded5c466ee50f11957959f08a94a715f80e732da83bc31b66a2bbff2bb4ac1402dbeddda219eada772267f34705b8891137b8d910e5229 SHA512 ea1416c041c857fc184fcce10862d93fce1de888396527d120b2d5f3cd041084d85f8ab4b36693d52786c7162bf41d61c9700ebc4509902c6fcd1c2e87130dfb
DIST hypothesis-python-5.16.2.tar.gz 9011495 BLAKE2B ecac1ddd0c214a06e8822fc04f9fd9378933b1c3721c1a3aabfa605d45df21b22b76a497f5fa1bef3009ceba52d582c9f69a0918fdcaf7df7b3c03405f8eb7a9 SHA512 91feb7b81c4c36468b05318c0db7ce3b607374b55bf2609bb587d316448f087fab44b99cde1cb5fc440df8d31ef2dd6c154281f13dd7bc6d1de4e463cdabf66a
+DIST hypothesis-python-5.16.3.tar.gz 9011952 BLAKE2B d74a68c4ee1e5aacf4be1da5a4656011b0a15f990106c21298101d36e9a097c5dfd165987ad90a45f3a0b74375c4da609cd750f618242b94f34e03b6de0ee866 SHA512 912d984995d4ad8f06e98eb2cc327629328990fc1c072527ce261b637e16622acaf4d0d93928f9dd2d6601ab78f69aa6cf129d5cd7c1c00e50754ebc06957df0
diff --git a/dev-python/hypothesis/hypothesis-5.16.3.ebuild b/dev-python/hypothesis/hypothesis-5.16.3.ebuild
new file mode 100644
index 000000000000..494668bd6a8e
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-5.16.3.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="https://github.com/HypothesisWorks/hypothesis https://pypi.org/project/hypothesis/"
+SRC_URI="https://github.com/HypothesisWorks/${PN}/archive/${PN}-python-${PV}.tar.gz"
+S="${WORKDIR}/${PN}-${PN}-python-${PV}/${PN}-python"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ >=dev-python/pytest-5.3.5[${PYTHON_USEDEP}]
+ !!<dev-python/typing-3.7.4.1
+ )
+"
+
+src_prepare() {
+ # avoid pytest-xdist dep for one test
+ sed -i -e 's:test_prints_statistics_given_option_under_xdist:_&:' \
+ tests/pytest/test_statistics.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ pytest -vv tests/cover tests/pytest tests/quality ||
+ die "Tests fail with ${EPYTHON}"
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}