summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/jaraco-envs/Manifest1
-rw-r--r--dev-python/jaraco-envs/jaraco-envs-2.6.0.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/jaraco-envs/Manifest b/dev-python/jaraco-envs/Manifest
index 140639959e89..0f747fe59cfb 100644
--- a/dev-python/jaraco-envs/Manifest
+++ b/dev-python/jaraco-envs/Manifest
@@ -1 +1,2 @@
DIST jaraco.envs-2.4.0.tar.gz 7101 BLAKE2B 0858732706a71ac359b97c0a841c5370f35011968ee76364a06aa67231992bd04e200362d245c3fe8d035b7018be15bdc4117a76e86ac35bb0fff8958af9a0f6 SHA512 d4da2a3f8ec9add63a0b2f754523da5b6593d869537e38c33ea86e59105c4be0cea15546897d70b869cf81be709d9b3fa2cfa35bbefcb9ab32a373ea620553aa
+DIST jaraco.envs-2.6.0.tar.gz 8028 BLAKE2B af9eb47e4f0856a3c3d7ae028e6cebbfc74a6502a5442aa9518b7ab0f927dbc0dcd5e68240dc43868ccb505b0d75c7e9e0162d54620765559f5643f13019a0ba SHA512 8c1d4717f45b805ae3afa1308a60c0f6f03af2a0976f2fb52329d05114282c2f33085865c93e34065bfd978e52ed8bd65f9903ed8e3c7d8b23bf6a050a32bd08
diff --git a/dev-python/jaraco-envs/jaraco-envs-2.6.0.ebuild b/dev-python/jaraco-envs/jaraco-envs-2.6.0.ebuild
new file mode 100644
index 000000000000..5bb7be7ddf01
--- /dev/null
+++ b/dev-python/jaraco-envs/jaraco-envs-2.6.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN=${PN/-/.}
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Classes for orchestrating Python (virtual) environments"
+HOMEPAGE="
+ https://github.com/jaraco/jaraco.envs/
+ https://pypi.org/project/jaraco.envs/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ dev-python/path[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # optional runtime dep, not used by anything in ::gentoo
+ sed -i -e '/tox/d' setup.cfg || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ epytest tests
+}