summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-shells/bash/bash-2.05b_p13.ebuild19
-rw-r--r--app-shells/bash/bash-3.0_p22.ebuild19
-rw-r--r--app-shells/bash/bash-3.1_p23.ebuild19
-rw-r--r--app-shells/bash/bash-3.2_p57.ebuild19
-rw-r--r--app-shells/bash/bash-4.0_p44.ebuild19
-rw-r--r--app-shells/bash/bash-4.1_p17.ebuild19
-rw-r--r--app-shells/bash/bash-4.2_p53.ebuild21
7 files changed, 64 insertions, 71 deletions
diff --git a/app-shells/bash/bash-2.05b_p13.ebuild b/app-shells/bash/bash-2.05b_p13.ebuild
index 56d5bcd6c655..1863ad9d4b6b 100644
--- a/app-shells/bash/bash-2.05b_p13.ebuild
+++ b/app-shells/bash/bash-2.05b_p13.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -35,12 +35,14 @@ SRC_URI="mirror://gnu/bash/${MY_P}.tar.gz $(patches)"
LICENSE="GPL-2"
SLOT="${MY_PV}"
KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~sparc-fbsd ~x86-fbsd"
-IUSE="afs +net nls +readline"
+IUSE="afs +net nls +readline static"
-DEPEND=">=sys-libs/ncurses-5.2-r2
- readline? ( >=sys-libs/readline-6.2 )
- nls? ( virtual/libintl )"
-RDEPEND="${DEPEND}"
+LIB_DEPEND=">=sys-libs/ncurses-5.2-r2[static-libs(+)]
+ nls? ( virtual/libintl )
+ readline? ( >=sys-libs/readline-6.2[static-libs(+)] )"
+RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs(+)]} )"
+DEPEND="${RDEPEND}
+ static? ( ${LIB_DEPEND} )"
S=${WORKDIR}/${MY_P}
@@ -95,10 +97,7 @@ src_configure() {
-DNON_INTERACTIVE_LOGIN_SHELLS \
-DSSH_SOURCE_BASHRC
- # Don't even think about building this statically without
- # reading Bug 7714 first. If you still build it statically,
- # don't come crying to us with bugs ;).
- #use static && export LDFLAGS="${LDFLAGS} -static"
+ use static && append-ldflags -static
use nls || myconf+=( --disable-nls )
# Historically, we always used the builtin readline, but since
diff --git a/app-shells/bash/bash-3.0_p22.ebuild b/app-shells/bash/bash-3.0_p22.ebuild
index 33a50c8c1bed..b1d557938f39 100644
--- a/app-shells/bash/bash-3.0_p22.ebuild
+++ b/app-shells/bash/bash-3.0_p22.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -35,12 +35,14 @@ SRC_URI="mirror://gnu/bash/${MY_P}.tar.gz $(patches)"
LICENSE="GPL-2"
SLOT="${MY_PV}"
KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~sparc-fbsd ~x86-fbsd"
-IUSE="afs +net nls +readline"
+IUSE="afs +net nls +readline static"
-DEPEND=">=sys-libs/ncurses-5.2-r2
- readline? ( >=sys-libs/readline-6.2 )
- nls? ( virtual/libintl )"
-RDEPEND="${DEPEND}"
+LIB_DEPEND=">=sys-libs/ncurses-5.2-r2[static-libs(+)]
+ nls? ( virtual/libintl )
+ readline? ( >=sys-libs/readline-6.2[static-libs(+)] )"
+RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs(+)]} )"
+DEPEND="${RDEPEND}
+ static? ( ${LIB_DEPEND} )"
S=${WORKDIR}/${MY_P}
@@ -103,10 +105,7 @@ src_configure() {
-DNON_INTERACTIVE_LOGIN_SHELLS \
-DSSH_SOURCE_BASHRC
- # Don't even think about building this statically without
- # reading Bug 7714 first. If you still build it statically,
- # don't come crying to us with bugs ;).
- #use static && export LDFLAGS="${LDFLAGS} -static"
+ use static && append-ldflags -static
use nls || myconf+=( --disable-nls )
# Historically, we always used the builtin readline, but since
diff --git a/app-shells/bash/bash-3.1_p23.ebuild b/app-shells/bash/bash-3.1_p23.ebuild
index d984d0d0575a..620cbe368ae5 100644
--- a/app-shells/bash/bash-3.1_p23.ebuild
+++ b/app-shells/bash/bash-3.1_p23.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -35,12 +35,14 @@ SRC_URI="mirror://gnu/bash/${MY_P}.tar.gz $(patches)"
LICENSE="GPL-2"
SLOT="${MY_PV}"
KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~sparc-fbsd ~x86-fbsd"
-IUSE="afs +net nls +readline"
+IUSE="afs +net nls +readline static"
-DEPEND=">=sys-libs/ncurses-5.2-r2
- readline? ( >=sys-libs/readline-6.2 )
- nls? ( virtual/libintl )"
-RDEPEND="${DEPEND}"
+LIB_DEPEND=">=sys-libs/ncurses-5.2-r2[static-libs(+)]
+ nls? ( virtual/libintl )
+ readline? ( >=sys-libs/readline-6.2[static-libs(+)] )"
+RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs(+)]} )"
+DEPEND="${RDEPEND}
+ static? ( ${LIB_DEPEND} )"
S=${WORKDIR}/${MY_P}
@@ -95,10 +97,7 @@ src_configure() {
-DNON_INTERACTIVE_LOGIN_SHELLS \
-DSSH_SOURCE_BASHRC
- # Don't even think about building this statically without
- # reading Bug 7714 first. If you still build it statically,
- # don't come crying to us with bugs ;).
- #use static && export LDFLAGS="${LDFLAGS} -static"
+ use static && append-ldflags -static
use nls || myconf+=( --disable-nls )
# Historically, we always used the builtin readline, but since
diff --git a/app-shells/bash/bash-3.2_p57.ebuild b/app-shells/bash/bash-3.2_p57.ebuild
index 511e7b22cdf6..d27032812a6d 100644
--- a/app-shells/bash/bash-3.2_p57.ebuild
+++ b/app-shells/bash/bash-3.2_p57.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -35,12 +35,14 @@ SRC_URI="mirror://gnu/bash/${MY_P}.tar.gz $(patches)"
LICENSE="GPL-2"
SLOT="${MY_PV}"
KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~sparc-fbsd ~x86-fbsd"
-IUSE="afs +net nls +readline"
+IUSE="afs +net nls +readline static"
-DEPEND=">=sys-libs/ncurses-5.2-r2
- readline? ( >=sys-libs/readline-6.2 )
- nls? ( virtual/libintl )"
-RDEPEND="${DEPEND}"
+LIB_DEPEND=">=sys-libs/ncurses-5.2-r2[static-libs(+)]
+ nls? ( virtual/libintl )
+ readline? ( >=sys-libs/readline-6.2[static-libs(+)] )"
+RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs(+)]} )"
+DEPEND="${RDEPEND}
+ static? ( ${LIB_DEPEND} )"
S=${WORKDIR}/${MY_P}
@@ -97,10 +99,7 @@ src_configure() {
-DNON_INTERACTIVE_LOGIN_SHELLS \
-DSSH_SOURCE_BASHRC
- # Don't even think about building this statically without
- # reading Bug 7714 first. If you still build it statically,
- # don't come crying to us with bugs ;).
- #use static && export LDFLAGS="${LDFLAGS} -static"
+ use static && append-ldflags -static
use nls || myconf+=( --disable-nls )
# Historically, we always used the builtin readline, but since
diff --git a/app-shells/bash/bash-4.0_p44.ebuild b/app-shells/bash/bash-4.0_p44.ebuild
index 2d8a80e01941..17211a6c3eff 100644
--- a/app-shells/bash/bash-4.0_p44.ebuild
+++ b/app-shells/bash/bash-4.0_p44.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -35,12 +35,14 @@ SRC_URI="mirror://gnu/bash/${MY_P}.tar.gz $(patches)"
LICENSE="GPL-3"
SLOT="${MY_PV}"
KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~sparc-fbsd ~x86-fbsd"
-IUSE="afs mem-scramble +net nls +readline"
+IUSE="afs mem-scramble +net nls +readline static"
-DEPEND=">=sys-libs/ncurses-5.2-r2
- readline? ( >=sys-libs/readline-6.2 )
- nls? ( virtual/libintl )"
-RDEPEND="${DEPEND}"
+LIB_DEPEND=">=sys-libs/ncurses-5.2-r2[static-libs(+)]
+ nls? ( virtual/libintl )
+ readline? ( >=sys-libs/readline-6.2[static-libs(+)] )"
+RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs(+)]} )"
+DEPEND="${RDEPEND}
+ static? ( ${LIB_DEPEND} )"
S=${WORKDIR}/${MY_P}
@@ -91,10 +93,7 @@ src_configure() {
-DNON_INTERACTIVE_LOGIN_SHELLS \
-DSSH_SOURCE_BASHRC
- # Don't even think about building this statically without
- # reading Bug 7714 first. If you still build it statically,
- # don't come crying to us with bugs ;).
- #use static && export LDFLAGS="${LDFLAGS} -static"
+ use static && append-ldflags -static
use nls || myconf+=( --disable-nls )
# Historically, we always used the builtin readline, but since
diff --git a/app-shells/bash/bash-4.1_p17.ebuild b/app-shells/bash/bash-4.1_p17.ebuild
index ad19cf367709..1d34fdd98aca 100644
--- a/app-shells/bash/bash-4.1_p17.ebuild
+++ b/app-shells/bash/bash-4.1_p17.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -35,12 +35,14 @@ SRC_URI="mirror://gnu/bash/${MY_P}.tar.gz $(patches)"
LICENSE="GPL-3"
SLOT="${MY_PV}"
KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~sparc-fbsd ~x86-fbsd"
-IUSE="afs mem-scramble +net nls +readline"
+IUSE="afs mem-scramble +net nls +readline static"
-DEPEND=">=sys-libs/ncurses-5.2-r2
- readline? ( >=sys-libs/readline-6.2 )
- nls? ( virtual/libintl )"
-RDEPEND="${DEPEND}"
+LIB_DEPEND=">=sys-libs/ncurses-5.2-r2[static-libs(+)]
+ nls? ( virtual/libintl )
+ readline? ( >=sys-libs/readline-6.2[static-libs(+)] )"
+RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs(+)]} )"
+DEPEND="${RDEPEND}
+ static? ( ${LIB_DEPEND} )"
S=${WORKDIR}/${MY_P}
@@ -88,10 +90,7 @@ src_configure() {
-DNON_INTERACTIVE_LOGIN_SHELLS \
-DSSH_SOURCE_BASHRC
- # Don't even think about building this statically without
- # reading Bug 7714 first. If you still build it statically,
- # don't come crying to us with bugs ;).
- #use static && export LDFLAGS="${LDFLAGS} -static"
+ use static && append-ldflags -static
use nls || myconf+=( --disable-nls )
# Historically, we always used the builtin readline, but since
diff --git a/app-shells/bash/bash-4.2_p53.ebuild b/app-shells/bash/bash-4.2_p53.ebuild
index 1705530d6509..98d2e555595c 100644
--- a/app-shells/bash/bash-4.2_p53.ebuild
+++ b/app-shells/bash/bash-4.2_p53.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -35,14 +35,16 @@ SRC_URI="mirror://gnu/bash/${MY_P}.tar.gz $(patches)"
LICENSE="GPL-3"
SLOT="${MY_PV}"
KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
-IUSE="afs mem-scramble +net nls +readline"
+IUSE="afs mem-scramble +net nls +readline static"
-DEPEND=">=sys-libs/ncurses-5.2-r2
- readline? ( >=sys-libs/readline-6.2 )
- nls? ( virtual/libintl )"
-RDEPEND="${DEPEND}"
+LIB_DEPEND=">=sys-libs/ncurses-5.2-r2[static-libs(+)]
+ nls? ( virtual/libintl )
+ readline? ( >=sys-libs/readline-6.2[static-libs(+)] )"
+RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs(+)]} )"
# we only need yacc when the .y files get patched (bash42-005)
-DEPEND+=" virtual/yacc"
+DEPEND="${RDEPEND}
+ virtual/yacc
+ static? ( ${LIB_DEPEND} )"
S=${WORKDIR}/${MY_P}
@@ -93,10 +95,7 @@ src_configure() {
-DNON_INTERACTIVE_LOGIN_SHELLS \
-DSSH_SOURCE_BASHRC
- # Don't even think about building this statically without
- # reading Bug 7714 first. If you still build it statically,
- # don't come crying to us with bugs ;).
- #use static && export LDFLAGS="${LDFLAGS} -static"
+ use static && append-ldflags -static
use nls || myconf+=( --disable-nls )
# Historically, we always used the builtin readline, but since