summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-misc/birdtray/Manifest1
-rw-r--r--x11-misc/birdtray/birdtray-1.8.0.ebuild38
-rw-r--r--x11-misc/birdtray/birdtray-9999.ebuild3
3 files changed, 40 insertions, 2 deletions
diff --git a/x11-misc/birdtray/Manifest b/x11-misc/birdtray/Manifest
index f1c41a1ba99b..096f0ef9a062 100644
--- a/x11-misc/birdtray/Manifest
+++ b/x11-misc/birdtray/Manifest
@@ -1 +1,2 @@
DIST birdtray-1.7.0.tar.gz 398153 BLAKE2B 87e583ab55b828213f5da97a61c3fc710b381b46ab688f02b6d1c4d01a2577451375d7366f0406cf685f1366497204e985de7905b1635161e252c11b9456da61 SHA512 3c2940a3a0e405d3fce1cd0411437ffa56f76c458e42ea059de1bd3fca802621643be39c1a0df3fc3fb0deac2aa53f7631c4bee191efd4b48e591dd05b30a6ab
+DIST birdtray-1.8.0.tar.gz 737802 BLAKE2B b3c52c4380a7d88cb7ab7abdc08979c03f1429564dfb568743c3698f6b7cc630b482181e0f3049fb3fc6e871cea23bf3e400e77ec17da7724f300bbb12f992c4 SHA512 6596b5e8c06b414b18b3256c3194d868ed42aab88486fa174b644d48640c15d2e33b198962e91e5b74e501c33f345cf3e160176a6928c789013076cce91a6eba
diff --git a/x11-misc/birdtray/birdtray-1.8.0.ebuild b/x11-misc/birdtray/birdtray-1.8.0.ebuild
new file mode 100644
index 000000000000..4820733d2bcb
--- /dev/null
+++ b/x11-misc/birdtray/birdtray-1.8.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake xdg-utils
+
+DESCRIPTION="A new mail system tray notification icon for Thunderbird"
+HOMEPAGE="https://github.com/gyunaev/birdtray"
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/gyunaev/birdtray.git"
+else
+ SRC_URI="https://github.com/gyunaev/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+
+RDEPEND="dev-db/sqlite:=
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ x11-libs/libX11"
+
+DEPEND="${RDEPEND}"
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}
diff --git a/x11-misc/birdtray/birdtray-9999.ebuild b/x11-misc/birdtray/birdtray-9999.ebuild
index 27005bff4ede..4820733d2bcb 100644
--- a/x11-misc/birdtray/birdtray-9999.ebuild
+++ b/x11-misc/birdtray/birdtray-9999.ebuild
@@ -12,9 +12,8 @@ if [[ ${PV} == "9999" ]] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/gyunaev/birdtray.git"
else
- SRC_URI="https://github.com/gyunaev/${PN}/archive/RELEASE_${PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="https://github.com/gyunaev/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64"
- S="${WORKDIR}/${PN}-RELEASE_${PV}"
fi
LICENSE="GPL-3"