summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-chemistry/gperiodic/Manifest1
-rw-r--r--sci-chemistry/gperiodic/gperiodic-3.0.3.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/sci-chemistry/gperiodic/Manifest b/sci-chemistry/gperiodic/Manifest
index 438e65f3dc0e..41e5410baf68 100644
--- a/sci-chemistry/gperiodic/Manifest
+++ b/sci-chemistry/gperiodic/Manifest
@@ -1,2 +1,3 @@
DIST gperiodic-2.0.10.tar.gz 131213 BLAKE2B bd846dd64afa07e038008e6fe0563f5743767f3a1fba1aad0122ae644c7fb9279657609733bc4e6d4f4dcf988aff6096431ba1b71d02a328e01376ae00ff9bcb SHA512 23d0074ad5b0f9e25e8eee63f8c375e2448b1ee7c00f89e965b7dd8ce3f60f20251d7699a2f7a767228316144b946a5ac204a3e478c395767133f7fc801b51ba
DIST gperiodic-3.0.1.tar.gz 375347 BLAKE2B fb10c7d3484e822e636a8aca245ab2a68a95cfebbb433df03a643a1155f300d2cdca49ddb5713d298c69a25123abbf72e17fdd51f69c9b031d05153937b283fc SHA512 3bf47359dda1a029f3528ea04d28cd75909bceb535f6e1dc6c90f5a17b668e0dd98900ddd83633649383ff4e2fc588265275e0e4a27897ecc4ac6db4e93befc1
+DIST gperiodic-3.0.3.tar.gz 451559 BLAKE2B b91995046b9905a534e3b6f530aee0ad2b4e6ac42cd11755ea182fdaaf8970f34b1aea8a33870abb8767837606a42a0cf0d76c9a689236aa39fba686e1521ee8 SHA512 7226063cf7977f4283a199d4a3d1842d6c9be60c53f5a005541eb26f35cd6538b29f086dc13c28225779e1849a12d1c39150897055c03902cb00adc011bc1ce8
diff --git a/sci-chemistry/gperiodic/gperiodic-3.0.3.ebuild b/sci-chemistry/gperiodic/gperiodic-3.0.3.ebuild
new file mode 100644
index 000000000000..a7c510e90e38
--- /dev/null
+++ b/sci-chemistry/gperiodic/gperiodic-3.0.3.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit eutils toolchain-funcs xdg-utils
+
+DESCRIPTION="Periodic table application for Linux"
+HOMEPAGE="https://sourceforge.net/projects/gperiodic/"
+SRC_URI="https://downloads.sourceforge.net/project/${PN}/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE="nls"
+MY_AVAILABLE_LINGUAS=" be bg cs da de es fi fr gl id is it lt ms nl pl pt_BR pt ru sv tr uk"
+
+RDEPEND="
+ sys-libs/ncurses:0
+ x11-libs/gtk+:2
+ x11-libs/cairo[X]
+ nls? ( sys-devel/gettext )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+ for lang in ${MY_AVAILABLE_LINGUAS}; do
+ if ! has ${lang} ${LINGUAS-${lang}}; then
+ einfo "Cleaning translation for ${lang}"
+ rm po/${lang}.po || die
+ fi
+ done
+}
+
+src_compile() {
+ local myopts
+ use nls && myopts="enable_nls=1" || myopts="enable_nls=0"
+ emake \
+ CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ CC=$(tc-getCC) ${myopts}
+}
+
+src_install() {
+ local myopts
+ use nls && myopts="enable_nls=1" || myopts="enable_nls=0"
+ emake DESTDIR="${D}" ${myopts} install
+ dodoc AUTHORS ChangeLog README
+ newdoc po/README README.translation
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}