summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/keyring/Manifest1
-rw-r--r--dev-python/keyring/keyring-23.2.1.ebuild46
2 files changed, 0 insertions, 47 deletions
diff --git a/dev-python/keyring/Manifest b/dev-python/keyring/Manifest
index fe302b0b00cd..f7059690758f 100644
--- a/dev-python/keyring/Manifest
+++ b/dev-python/keyring/Manifest
@@ -1,3 +1,2 @@
-DIST keyring-23.2.1.tar.gz 44522 BLAKE2B 79ba1fb530cecad84ba94e9a27f32196367af92952946c07581d68d5e89fac93d9b7a33cad8d1a95ae9ffe1568ddc189cd17decea7113debb022dafba4472bfd SHA512 205f74d9457f65952b1cada1a829bb97318cb80689b410eedb49def3577234f715ec6420d7d12833255ef5098040d0a5186be47fa6b8c6db6036406c3ee2e246
DIST keyring-23.3.0.tar.gz 44669 BLAKE2B 3f6cd3ff558b0a792d405c1c8175bf68c8463f26662d74c1f439e28d7914ef7f26c6091c64ef372e78028eeda04d2a5bcbe253477632b2e53d92d36ade43d47a SHA512 39264abf585949da444fdacbb1195c981157e151d1d14373c5afe0f6547f8da46b2da3e14f47e363bbccd69ee90bc182c287bd963d8b99301a5e919e511426cf
DIST keyring-23.4.0.tar.gz 44557 BLAKE2B 1115ecfca9f7d7cd5d28168d9d4198e329217ace82a32fe4db1b40aa96e6a352face46f4e8877407618e701713a8f1347810a24706bbe1872bff758f71ae34f5 SHA512 214041375a1bddda099042168f0f4c5ea4cf24c347a0693ab3efd7eb7a0ab2c36abff33f3d83168cfe5ae5dd971e0f3de4548fb0651e435009766aec740e64eb
diff --git a/dev-python/keyring/keyring-23.2.1.ebuild b/dev-python/keyring/keyring-23.2.1.ebuild
deleted file mode 100644
index f96cd174d7d8..000000000000
--- a/dev-python/keyring/keyring-23.2.1.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( pypy3 python3_{8..10} )
-inherit distutils-r1
-
-DESCRIPTION="Provides access to the system keyring service"
-HOMEPAGE="https://github.com/jaraco/keyring"
-SRC_URI="https://github.com/jaraco/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-SLOT="0"
-LICENSE="PSF-2"
-KEYWORDS="~alpha amd64 arm arm64 hppa ppc ppc64 ~riscv sparc x86 ~x64-macos"
-
-RDEPEND="
- dev-python/secretstorage[${PYTHON_USEDEP}]
- dev-python/entrypoints[${PYTHON_USEDEP}]
- dev-python/jeepney[${PYTHON_USEDEP}]
- dev-python/importlib_metadata[${PYTHON_USEDEP}]
-"
-BDEPEND="
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
- dev-python/toml[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests pytest
-distutils_enable_sphinx docs \
- dev-python/jaraco-packaging \
- dev-python/rst-linker
-
-export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
-
-EPYTEST_DESELECT=(
- # this test fails if importlib-metadata returns more than one
- # entry, i.e. when keyring is installed already
- tests/test_packaging.py::test_entry_point
-)
-
-EPYTEST_IGNORE=(
- # apparently does not unlock the keyring properly
- tests/backends/test_libsecret.py
- # hangs
- tests/backends/test_kwallet.py
-)