summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/twine/Manifest1
-rw-r--r--dev-python/twine/twine-3.4.1.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/twine/Manifest b/dev-python/twine/Manifest
index a91b4e931df5..01d4ea27fc40 100644
--- a/dev-python/twine/Manifest
+++ b/dev-python/twine/Manifest
@@ -1,2 +1,3 @@
DIST twine-3.3.0.tar.gz 148996 BLAKE2B 60668acd0481534631ca0ecf3c755df7e9e46c6d183d0f1c73ed7467cfecc144878d6ccf7ef2ee62efa17eb5629f5ed74c77c8ae4d57ef16530fad31afe40d97 SHA512 94fc7a9b3f2b5fc7c06baf55debf4fd55f6a2b4c4321c9bff46b844166769ce8bdcab10355c4967998149b62e13b26e11a30ff66042bfdd5af24d448321fd291
DIST twine-3.4.0.tar.gz 211582 BLAKE2B 6b309880e96142a666f0113343f6a7a604ec6058f58429befa4709366d8dd8b6ddd0d2cd69d74653d12a74a615e6e3ad6b7d96892aa5beab00c934be2fc4b8d6 SHA512 6ce4757048fe7b5ada8a384fa185e80cee8412ef7f0561f55a5cbec39c0069522b57e403f148b9b55c55330a577873a5e9597ca0a6b0fb0cce6b377c8df07e4e
+DIST twine-3.4.1.tar.gz 211775 BLAKE2B 0fdc6a8f5a37ee9695c8db2080987b631dfe6f8ed718e3912c94d77b46d35682d27bef07715c1fe7c0d8b6ab1449a771e18d8ffa5c6044dde1536b56b3e7885e SHA512 eca2a7b6b1386868f67dec1182599a8331981585e1cc0b7eef762aa0e99b87b0c6725a2c776330a8b392254501880a68e01ed8569a169857e8079abb8da43b79
diff --git a/dev-python/twine/twine-3.4.1.ebuild b/dev-python/twine/twine-3.4.1.ebuild
new file mode 100644
index 000000000000..58a2549a393e
--- /dev/null
+++ b/dev-python/twine/twine-3.4.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{7..9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Collection of utilities for publishing packages on PyPI"
+HOMEPAGE="https://twine.readthedocs.io/ https://github.com/pypa/twine https://pypi.org/project/twine/"
+SRC_URI="https://github.com/pypa/twine/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ >=dev-python/colorama-0.4.3[${PYTHON_USEDEP}]
+ >=dev-python/importlib_metadata-3.6[${PYTHON_USEDEP}]
+ >=dev-python/keyring-15.1[${PYTHON_USEDEP}]
+ >=dev-python/pkginfo-1.4.2[${PYTHON_USEDEP}]
+ >=dev-python/readme_renderer-21.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.20.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-toolbelt-0.8.0[${PYTHON_USEDEP}]
+ >=dev-python/rfc3986-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/tqdm-4.14[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/jaraco-envs[${PYTHON_USEDEP}]
+ dev-python/jaraco-functools[${PYTHON_USEDEP}]
+ dev-python/munch[${PYTHON_USEDEP}]
+ dev-python/portend[${PYTHON_USEDEP}]
+ dev-python/pretend[${PYTHON_USEDEP}]
+ dev-python/pypiserver[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests --install pytest
+
+python_prepare_all() {
+ # requires internet
+ rm -f tests/test_integration.py || die
+ # pytest-socket dep relevant only to test_integration, and upstream
+ # disables it anyway
+ sed -i -e '/--disable-socket/d' pytest.ini || die
+ sed -i -e '/--cov/d' pytest.ini || die
+
+ distutils-r1_python_prepare_all
+ export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+}