summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/django-otp/Manifest1
-rw-r--r--dev-python/django-otp/django-otp-0.4.3.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/django-otp/Manifest b/dev-python/django-otp/Manifest
index 547646c96182..28515881f3c5 100644
--- a/dev-python/django-otp/Manifest
+++ b/dev-python/django-otp/Manifest
@@ -1 +1,2 @@
DIST django-otp-0.3.4.tar.gz 39992 BLAKE2B e85cee8d868038aa936a8a3bd7dfd326a28a7609f3a6273637e075fb971dba27060b39f18773628c6a963525a0aa83328d72de937957f430629b8ad6fa77e127 SHA512 62b6683050a9dbd0bcfc9a63bd965f19e5d088c3e53c5e45067f8a785aa7b2a7b540d0331742bf8b979ad95d308f944bfef250989d1f782849a71bbc79a7d53c
+DIST django-otp-0.4.3.tar.gz 42480 BLAKE2B 09398e4e06425fefdda45a3a200576efda9409a42fb8f1c640a996e066e1ad2cf47e6ee0879e4a61cdc64808fe8f030aba19dfd99fa4da7d3e86597bda881d09 SHA512 3f3ec761dc12ed40e8c757dfbe1fd951c7c6aed3abc311c823acdeca08d5864b54c8442a49807228be17b30c20093b1ba7fb8b2c0f86f00dc1cc215ccd7c28de
diff --git a/dev-python/django-otp/django-otp-0.4.3.ebuild b/dev-python/django-otp/django-otp-0.4.3.ebuild
new file mode 100644
index 000000000000..2f62c4dcbb8b
--- /dev/null
+++ b/dev-python/django-otp/django-otp-0.4.3.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Django framework adding two-factor authentication using one-time passwords"
+HOMEPAGE="https://bitbucket.org/psagers/django-otp"
+SRC_URI="mirror://pypi/d/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-python/django-1.8[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"