summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-misc/kea/files/kea-1.8.2-fix-cxx11-detection.patch50
-rw-r--r--net-misc/kea/kea-1.8.2.ebuild5
2 files changed, 54 insertions, 1 deletions
diff --git a/net-misc/kea/files/kea-1.8.2-fix-cxx11-detection.patch b/net-misc/kea/files/kea-1.8.2-fix-cxx11-detection.patch
new file mode 100644
index 000000000000..867561f2e7e5
--- /dev/null
+++ b/net-misc/kea/files/kea-1.8.2-fix-cxx11-detection.patch
@@ -0,0 +1,50 @@
+--- a/m4macros/ax_cpp11.m4
++++ b/m4macros/ax_cpp11.m4
+@@ -182,6 +182,7 @@
+ AC_COMPILE_IFELSE(
+ [AC_LANG_PROGRAM(
+ [#include <thread>
++ #include <memory>
+ std::shared_ptr<std::thread> th;],
+ [th.reset(new std::thread([[]]() { return; }));
+ th->join();])],
+--- a/src/bin/perfdhcp/Makefile.am
++++ b/src/bin/perfdhcp/Makefile.am
+@@ -3,7 +3,6 @@
+ AM_CPPFLAGS = -I$(top_srcdir)/src/lib -I$(top_builddir)/src/lib
+ AM_CPPFLAGS += -I$(top_srcdir)/src/bin -I$(top_builddir)/src/bin
+ AM_CPPFLAGS += $(BOOST_INCLUDES)
+-AM_CPPFLAGS += -Werror
+
+ AM_CXXFLAGS = $(KEA_CXXFLAGS)
+
+--- a/src/bin/perfdhcp/tests/Makefile.am
++++ b/src/bin/perfdhcp/tests/Makefile.am
+@@ -4,7 +4,6 @@
+ AM_CPPFLAGS += -I$(srcdir)/.. -I$(builddir)/..
+ AM_CPPFLAGS += -DTEST_DATA_DIR=\"$(abs_srcdir)/testdata\"
+ AM_CPPFLAGS += $(BOOST_INCLUDES)
+-AM_CPPFLAGS += -Werror
+ AM_CXXFLAGS = $(KEA_CXXFLAGS)
+
+ if USE_STATIC_LINK
+--- a/src/lib/database/backend_selector.cc
++++ b/src/lib/database/backend_selector.cc
+@@ -7,6 +7,7 @@
+ #include <database/backend_selector.h>
+ #include <exceptions/exceptions.h>
+ #include <climits>
++#include <limits>
+ #include <sstream>
+
+ using namespace isc::data;
+--- a/src/lib/dhcpsrv/subnet_id.h
++++ b/src/lib/dhcpsrv/subnet_id.h
+@@ -10,6 +10,7 @@
+ #include <exceptions/exceptions.h>
+ #include <stdint.h>
+ #include <typeinfo>
++#include <limits>
+
+ namespace isc {
+ namespace dhcp {
diff --git a/net-misc/kea/kea-1.8.2.ebuild b/net-misc/kea/kea-1.8.2.ebuild
index ef18946d46ac..8fa2128e5ae0 100644
--- a/net-misc/kea/kea-1.8.2.ebuild
+++ b/net-misc/kea/kea-1.8.2.ebuild
@@ -13,6 +13,7 @@ if [[ ${PV} = 9999* ]] ; then
inherit autotools git-r3
EGIT_REPO_URI="https://github.com/isc-projects/kea.git"
else
+ inherit autotools
SRC_URI="ftp://ftp.isc.org/isc/kea/${MY_P}.tar.gz
ftp://ftp.isc.org/isc/kea/${MY_PV}/${MY_P}.tar.gz"
[[ "${PV}" == *_beta* ]] || [[ "${PV}" == *_rc* ]] || \
@@ -39,9 +40,11 @@ BDEPEND="virtual/pkgconfig"
S="${WORKDIR}/${MY_P}"
+PATCHES=( "${FILESDIR}"/${PN}-1.8.2-fix-cxx11-detection.patch )
+
src_prepare() {
default
- [[ ${PV} = *9999 ]] && eautoreconf
+ eautoreconf
# Brand the version with Gentoo
sed -i \
-e "/VERSION=/s:'$: Gentoo-${PR}':" \