summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-haskell/parsec/Manifest1
-rw-r--r--dev-haskell/parsec/metadata.xml4
-rw-r--r--dev-haskell/parsec/parsec-3.1.14.0-r2.ebuild (renamed from dev-haskell/parsec/parsec-3.1.14.0-r1.ebuild)30
3 files changed, 19 insertions, 16 deletions
diff --git a/dev-haskell/parsec/Manifest b/dev-haskell/parsec/Manifest
index 32a912d49a6c..917d10325963 100644
--- a/dev-haskell/parsec/Manifest
+++ b/dev-haskell/parsec/Manifest
@@ -1 +1,2 @@
+DIST parsec-3.1.14.0-rev4.cabal 4356 BLAKE2B 6c0d7b4ae6c2adad8e79eee1f90ce51b6451b5929bddbd553e9a58cf4f9c169d48910ed8a6254afec54c096caf473230ce3f5672da60c4c170dcadfe9e1d1120 SHA512 4f5cef855f39497f7c84cb9f033cde9b8326a38a81d6ed1dab310078a935a14f36aa3f660b0ff1ef73333841c603c4a28237e96df1737de70ba9f88df84780c1
DIST parsec-3.1.14.0.tar.gz 35688 BLAKE2B 474b14ff35d332339ce07f09ef22cbbdf971de9d9712848eb1c67b7ea4359e46079b67d39f978755c7560c55baf6d5f0d69a425291644a3ff638139a8bbec3ce SHA512 db14f77a2d36da5e540be35f0facb7fa61f2c46057b98039bdf16c06fe9865d5ee47e3523a312201665ca133f3f93855b42f0d0a920b8e233ffc8274075c56d3
diff --git a/dev-haskell/parsec/metadata.xml b/dev-haskell/parsec/metadata.xml
index 34bd558d2be0..443ee87b2842 100644
--- a/dev-haskell/parsec/metadata.xml
+++ b/dev-haskell/parsec/metadata.xml
@@ -13,4 +13,8 @@
stacked on arbitrary monads, and it is also parametric in the
input stream type.
</longdescription>
+ <upstream>
+ <remote-id type="hackage">parsec</remote-id>
+ <remote-id type="github">haskell/parsec</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/dev-haskell/parsec/parsec-3.1.14.0-r1.ebuild b/dev-haskell/parsec/parsec-3.1.14.0-r2.ebuild
index 198a26235898..3f56195eee38 100644
--- a/dev-haskell/parsec/parsec-3.1.14.0-r1.ebuild
+++ b/dev-haskell/parsec/parsec-3.1.14.0-r2.ebuild
@@ -3,9 +3,11 @@
EAPI=8
-# ebuild generated by hackport 0.7.1.1.9999
+# ebuild generated by hackport 0.8.0.0.9999
-CABAL_FEATURES="lib profile haddock hoogle hscolour" # Circular depens: test-suite"
+CABAL_HACKAGE_REVISION=4
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour" # Circular depends: test-suite
# break circular dependencies:
# https://github.com/gentoo-haskell/gentoo-haskell/issues/810
CABAL_FEATURES+=" nocabaldep"
@@ -13,27 +15,23 @@ inherit haskell-cabal
DESCRIPTION="Monadic parser combinators"
HOMEPAGE="https://github.com/haskell/parsec"
-SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"
-# keep in sync with ghc-8.8
+# Keep in sync with relevant ghc versions (CABAL_CORE_LIB_GHC_PV)
KEYWORDS="amd64 ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
RESTRICT=test # circular dependencies: dev-haskell/base-orphans->cabal->parsec[test]->test-framework-hunit->test-framework->base-orphans
-RDEPEND=">=dev-haskell/mtl-1.1.1:=[profile?] <dev-haskell/mtl-2.3:=[profile?]
- >=dev-lang/ghc-7.4.1:=
- >=dev-haskell/text-0.11.3.1:=[profile?] <dev-haskell/text-1.3:=[profile?]
+RDEPEND="
+ >=dev-lang/ghc-8.10.6:=
+"
+DEPEND="${RDEPEND}
"
-DEPEND="${RDEPEND}"
+# test? (
+# >=dev-haskell/test-framework-0.8 <dev-haskell/test-framework-0.9
+# >=dev-haskell/test-framework-hunit-0.3 <dev-haskell/test-framework-hunit-0.4
+# >=dev-haskell/hunit-1.6 <dev-haskell/hunit-1.7
+# )
CABAL_CORE_LIB_GHC_PV="8.8.4 8.10.4 8.10.5 8.10.6 8.10.7 9.0.1 9.0.2 PM:9999"
-
-src_prepare() {
- default
- cabal_chdeps \
- 'base >= 4.5.0 && < 4.14' 'base >= 4.5.0' \
- 'bytestring >= 0.9.2.1 && < 0.11' 'bytestring >= 0.9.2.1' \
- 'semigroups >= 0.18 && < 0.20' 'semigroups >= 0.18'
-}