summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-office/libreoffice/libreoffice-5.1.9999.ebuild6
-rw-r--r--app-office/libreoffice/libreoffice-5.2.9999.ebuild6
-rw-r--r--app-office/libreoffice/libreoffice-9999.ebuild6
-rw-r--r--app-office/libreoffice/metadata.xml1
4 files changed, 7 insertions, 12 deletions
diff --git a/app-office/libreoffice/libreoffice-5.1.9999.ebuild b/app-office/libreoffice/libreoffice-5.1.9999.ebuild
index 22da8a7a6c9e..164ac1e7ad29 100644
--- a/app-office/libreoffice/libreoffice-5.1.9999.ebuild
+++ b/app-office/libreoffice/libreoffice-5.1.9999.ebuild
@@ -79,7 +79,7 @@ unset ADDONS_SRC
LO_EXTS="nlpsolver scripting-beanshell scripting-javascript wiki-publisher"
IUSE="bluetooth +branding coinmp collada +cups dbus debug eds firebird gltf gnome google
-gstreamer +gtk gtk3 jemalloc kde libressl mysql odk postgres telepathy test vlc
+gstreamer +gtk gtk3 jemalloc kde libressl mysql odk postgres quickstarter telepathy test vlc
$(printf 'libreoffice_extensions_%s ' ${LO_EXTS})"
LICENSE="|| ( LGPL-3 MPL-1.1 )"
@@ -411,8 +411,6 @@ src_configure() {
# --enable-*-link: link to the library rather than just dlopen on runtime
# --enable-release-build: build the libreoffice as release
# --disable-fetch-external: prevent dowloading during compile phase
- # --disable-systray: quickstarter does not actually work at all so do not
- # promote it
# --enable-extension-integration: enable any extension integration support
# --without-{fonts,myspell-dicts,ppsd}: prevent install of sys pkgs
# --disable-report-builder: too much java packages pulled in without pkgs
@@ -440,7 +438,6 @@ src_configure() {
--disable-gstreamer-0-10 \
--disable-report-builder \
--disable-online-update \
- --disable-systray \
--with-alloc=$(use jemalloc && echo "jemalloc" || echo "system") \
--with-build-version="Gentoo official package" \
--enable-extension-integration \
@@ -476,6 +473,7 @@ src_configure() {
$(use_enable mysql ext-mariadb-connector) \
$(use_enable odk) \
$(use_enable postgres postgresql-sdbc) \
+ $(use_enable quickstarter systray) \
$(use_enable telepathy) \
$(use_enable vlc) \
$(use_with coinmp system-coinmp) \
diff --git a/app-office/libreoffice/libreoffice-5.2.9999.ebuild b/app-office/libreoffice/libreoffice-5.2.9999.ebuild
index 8f34304e9332..7c0b3e41ca14 100644
--- a/app-office/libreoffice/libreoffice-5.2.9999.ebuild
+++ b/app-office/libreoffice/libreoffice-5.2.9999.ebuild
@@ -78,7 +78,7 @@ unset ADDONS_SRC
LO_EXTS="nlpsolver scripting-beanshell scripting-javascript wiki-publisher"
IUSE="bluetooth +branding coinmp collada +cups dbus debug eds firebird gltf gnome google
-gstreamer +gtk gtk3 jemalloc kde libressl mysql odk postgres telepathy test vlc
+gstreamer +gtk gtk3 jemalloc kde libressl mysql odk postgres quickstarter telepathy test vlc
$(printf 'libreoffice_extensions_%s ' ${LO_EXTS})"
LICENSE="|| ( LGPL-3 MPL-1.1 )"
@@ -398,8 +398,6 @@ src_configure() {
# --enable-*-link: link to the library rather than just dlopen on runtime
# --enable-release-build: build the libreoffice as release
# --disable-fetch-external: prevent dowloading during compile phase
- # --disable-systray: quickstarter does not actually work at all so do not
- # promote it
# --enable-extension-integration: enable any extension integration support
# --without-{fonts,myspell-dicts,ppsd}: prevent install of sys pkgs
# --disable-report-builder: too much java packages pulled in without pkgs
@@ -428,7 +426,6 @@ src_configure() {
--disable-hardlink-deliver \
--disable-online-update \
--disable-report-builder \
- --disable-systray \
--with-alloc=$(use jemalloc && echo "jemalloc" || echo "system") \
--with-build-version="Gentoo official package" \
--enable-extension-integration \
@@ -465,6 +462,7 @@ src_configure() {
$(use_enable mysql ext-mariadb-connector) \
$(use_enable odk) \
$(use_enable postgres postgresql-sdbc) \
+ $(use_enable quickstarter systray) \
$(use_enable telepathy) \
$(use_enable vlc) \
$(use_with coinmp system-coinmp) \
diff --git a/app-office/libreoffice/libreoffice-9999.ebuild b/app-office/libreoffice/libreoffice-9999.ebuild
index dd6783864313..94771b792f60 100644
--- a/app-office/libreoffice/libreoffice-9999.ebuild
+++ b/app-office/libreoffice/libreoffice-9999.ebuild
@@ -78,7 +78,7 @@ unset ADDONS_SRC
LO_EXTS="nlpsolver scripting-beanshell scripting-javascript wiki-publisher"
IUSE="bluetooth +branding coinmp collada +cups dbus debug eds firebird gltf gnome google
-gstreamer +gtk gtk3 jemalloc kde libressl mysql odk postgres telepathy test vlc
+gstreamer +gtk gtk3 jemalloc kde libressl mysql odk postgres quickstarter telepathy test vlc
$(printf 'libreoffice_extensions_%s ' ${LO_EXTS})"
LICENSE="|| ( LGPL-3 MPL-1.1 )"
@@ -399,8 +399,6 @@ src_configure() {
# --enable-*-link: link to the library rather than just dlopen on runtime
# --enable-release-build: build the libreoffice as release
# --disable-fetch-external: prevent dowloading during compile phase
- # --disable-systray: quickstarter does not actually work at all so do not
- # promote it
# --enable-extension-integration: enable any extension integration support
# --without-{fonts,myspell-dicts,ppsd}: prevent install of sys pkgs
# --disable-report-builder: too much java packages pulled in without pkgs
@@ -429,7 +427,6 @@ src_configure() {
--disable-hardlink-deliver \
--disable-online-update \
--disable-report-builder \
- --disable-systray \
--with-alloc=$(use jemalloc && echo "jemalloc" || echo "system") \
--with-build-version="Gentoo official package" \
--enable-extension-integration \
@@ -466,6 +463,7 @@ src_configure() {
$(use_enable mysql ext-mariadb-connector) \
$(use_enable odk) \
$(use_enable postgres postgresql-sdbc) \
+ $(use_enable quickstarter systray) \
$(use_enable telepathy) \
$(use_enable vlc) \
$(use_with coinmp system-coinmp) \
diff --git a/app-office/libreoffice/metadata.xml b/app-office/libreoffice/metadata.xml
index f2a30d660fe9..e1f2f4716caf 100644
--- a/app-office/libreoffice/metadata.xml
+++ b/app-office/libreoffice/metadata.xml
@@ -18,6 +18,7 @@ version</longdescription>
<flag name="gtk3">Enable highly experimental gtk3 frontend</flag>
<flag name="jemalloc">Use <pkg>dev-libs/jemalloc</pkg> for allocations</flag>
<flag name="odk">Build the Office Development Kit</flag>
+ <flag name="quickstarter">Build the system tray quickstarter</flag>
<flag name="telepathy">Enable document colaboration features using telepathy communication framework.</flag>
<flag name="vlc">Use <pkg>media-video/vlc</pkg> for video embedding</flag>
</use>