summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ruby/diff-lcs/Manifest1
-rw-r--r--dev-ruby/diff-lcs/diff-lcs-1.4.ebuild19
2 files changed, 20 insertions, 0 deletions
diff --git a/dev-ruby/diff-lcs/Manifest b/dev-ruby/diff-lcs/Manifest
index 430e37978c38..62199d0286ea 100644
--- a/dev-ruby/diff-lcs/Manifest
+++ b/dev-ruby/diff-lcs/Manifest
@@ -1 +1,2 @@
DIST diff-lcs-1.3.gem 46080 BLAKE2B 907536d75c34de86ef28fa044ae785d8ba34c8d1f4d38964f08ef80c14a4fb6176504a39c2e074fb58fc5456214555461a18ae42dc04f371d85dd335b1cbc3dc SHA512 b82de390d22e0c1337ddca923621b1cc842f583a93953ef07a303b428fe3a389f8a4a1a63617a58136c8d6215aff025a3bbec2a2f618e9ea81f471964f93b078
+DIST diff-lcs-1.4.gem 48128 BLAKE2B 6ec3259dc366769c4008c6ea6c7e5f1fe75350dc0318c8d45991bb8173274630b3be734fe6375dbb131620d8124faa7c0567e57d299393c3165b0e1c2d29c138 SHA512 a352fdfb89587b38f3e518f76dddd048530501080dba5abb0c37033f44bee65bca12550ea7d6f1edb8a719092538c20d1c58dfe7a6f67ba1d46549608c09feae
diff --git a/dev-ruby/diff-lcs/diff-lcs-1.4.ebuild b/dev-ruby/diff-lcs/diff-lcs-1.4.ebuild
new file mode 100644
index 000000000000..83d94225b6f1
--- /dev/null
+++ b/dev-ruby/diff-lcs/diff-lcs-1.4.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="README.rdoc History.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Use the McIlroy-Hunt LCS algorithm to compute differences"
+HOMEPAGE="https://github.com/halostatue/diff-lcs"
+
+LICENSE="|| ( MIT Ruby GPL-2 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""