summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-analyzer/iplog/iplog-2.2.3-r3.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/net-analyzer/iplog/iplog-2.2.3-r3.ebuild b/net-analyzer/iplog/iplog-2.2.3-r3.ebuild
new file mode 100644
index 000000000000..09cfb969491a
--- /dev/null
+++ b/net-analyzer/iplog/iplog-2.2.3-r3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="TCP/IP traffic logger"
+HOMEPAGE="http://ojnk.sourceforge.net/"
+SRC_URI="mirror://sourceforge/ojnk/${P}.tar.gz"
+
+LICENSE="|| ( GPL-2 FDL-1.1 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~mips ~ppc ~sparc ~x86"
+
+DEPEND="net-libs/libpcap"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}"/${PV}-DLT_LINUX_SSL.patch )
+
+DOCS=( AUTHORS NEWS README TODO example-iplog.conf )
+
+src_compile() {
+ append-cppflags -D_REENTRANT
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" CPPFLAGS="${CPPFLAGS}" all
+}
+
+src_install() {
+ default
+ newinitd "${FILESDIR}"/iplog.rc6 iplog
+}