summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www-apps/sfpg/Manifest1
-rw-r--r--www-apps/sfpg/metadata.xml17
-rw-r--r--www-apps/sfpg/sfpg-4.9.0.ebuild44
3 files changed, 62 insertions, 0 deletions
diff --git a/www-apps/sfpg/Manifest b/www-apps/sfpg/Manifest
new file mode 100644
index 000000000000..c07796c625f7
--- /dev/null
+++ b/www-apps/sfpg/Manifest
@@ -0,0 +1 @@
+DIST Single_File_PHP_Gallery_4.9.0.zip 43058 BLAKE2B 27eb6362f28b1d24d77d8e9ccfdf83814ca4de0c0e1a2d1a94345e6c4b0c5b95b223c2bf5186f64a83fae392d2f8bdf7eb4e77c5295a86b279ce0abc7cb625cf SHA512 511889ff9c8680dd49d5c982609508b73c9baa5a2d8f7e8f6642003ce9e9f1feec248d9da3c69a4363ddc7ef6c77652697c0fa30f51ba490c2c926428ac8482c
diff --git a/www-apps/sfpg/metadata.xml b/www-apps/sfpg/metadata.xml
new file mode 100644
index 000000000000..8d38f85fa08c
--- /dev/null
+++ b/www-apps/sfpg/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>conikost@gentoo.org</email>
+ <name>Conrad Kostecki</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <longdescription>
+ Single File PHP Gallery is a web gallery in one single PHP file.
+ All you have to do is copy the script to any directory containing
+ images to make a gallery. Sub directories will be sub galleries.
+ Thumbnails for images and directories are generated automatically.
+ Single File PHP Gallery does not require any configuration
+ or programming skills to use.
+ </longdescription>
+</pkgmetadata>
diff --git a/www-apps/sfpg/sfpg-4.9.0.ebuild b/www-apps/sfpg/sfpg-4.9.0.ebuild
new file mode 100644
index 000000000000..b57ac1408b7d
--- /dev/null
+++ b/www-apps/sfpg/sfpg-4.9.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit webapp
+
+MY_PN="${PN^^}"
+MY_PV="fd8fa70739d18d786e88f7ffa57e250e0e41af8f"
+
+DESCRIPTION="A web gallery in one single PHP file"
+HOMEPAGE="https://sye.dk/sfpg/"
+SRC_URI="https://sye.dk/sfpg/Single_File_PHP_Gallery_${PV}.zip"
+S="${WORKDIR}"
+
+LICENSE="sfpg"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="bindist mirror"
+
+RDEPEND="
+ dev-lang/php[gd]
+ virtual/httpd-php
+"
+
+BDEPEND="app-arch/unzip"
+
+need_httpd_cgi
+
+DOCS=( "readme.txt" )
+
+src_install() {
+ webapp_src_preinst
+
+ einstalldocs
+
+ insinto "${MY_HTDOCSDIR}"
+ doins index.php
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ webapp_pkg_postinst
+}