summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-perl/GD/GD-2.560.0-r1.ebuild6
-rw-r--r--dev-perl/GD/files/GD-2.560.0-rt106594.patch40
-rw-r--r--dev-perl/GD/metadata.xml1
3 files changed, 45 insertions, 2 deletions
diff --git a/dev-perl/GD/GD-2.560.0-r1.ebuild b/dev-perl/GD/GD-2.560.0-r1.ebuild
index 9366bb032eaa..d419bf42c264 100644
--- a/dev-perl/GD/GD-2.560.0-r1.ebuild
+++ b/dev-perl/GD/GD-2.560.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -13,7 +13,9 @@ DESCRIPTION="Interface to Thomas Boutell's gd library"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x86-solaris"
IUSE="animgif gif jpeg png truetype xpm"
-
+PATCHES=(
+ "${FILESDIR}/${P}-rt106594.patch"
+)
RDEPEND="
virtual/perl-Math-Complex
>=media-libs/gd-2.0.33
diff --git a/dev-perl/GD/files/GD-2.560.0-rt106594.patch b/dev-perl/GD/files/GD-2.560.0-rt106594.patch
new file mode 100644
index 000000000000..dc8007d5d493
--- /dev/null
+++ b/dev-perl/GD/files/GD-2.560.0-rt106594.patch
@@ -0,0 +1,40 @@
+diff -Naur GD-2.56/t/GD.t GD-2.56b/t/GD.t
+--- GD-2.56/t/GD.t 2014-10-28 01:34:54.000000000 +0000
++++ GD-2.56b/t/GD.t 2016-05-10 10:05:05.838356122 +0000
+@@ -7,8 +7,8 @@
+ use FindBin qw($Bin);
+ use lib "$Bin/../blib/lib","$Bin/../blib/arch","$Bin/../lib";
+ use constant FONT=>"$Bin/test_data/Generic.ttf";
+-use constant IMAGE_TESTS => 7;
+-use Test::More tests => 11;
++use constant IMAGE_TESTS => 6;
++use Test::More tests => 10;
+ use IO::Dir;
+
+ use_ok('GD',':DEFAULT',':cmp');
+@@ -219,25 +219,6 @@
+ return $im;
+ }
+
+-sub test7 {
+- my $im = GD::Image->new(400,250);
+- if (!$im) { printf("Test7: no image");};
+- my($white,$black,$red,$blue,$yellow) =
+- (
+- $im->colorAllocate(255, 255, 255),
+- $im->colorAllocate(0, 0, 0),
+- $im->colorAllocate(255, 0, 0),
+- $im->colorAllocate(0,0,255),
+- $im->colorAllocate(255,250,205)
+- );
+-
+- # Some TTFs
+- $im->stringFT($black,FONT,12.0,0.0,20,20,"Hello world!") || warn $@;
+- $im->stringFT($red,FONT,14.0,0.0,20,80,"Hello world!") || warn $@;
+- $im->stringFT($blue,FONT,30.0,-0.5,60,100,"Goodbye cruel world!") || warn $@;
+- return $im;
+-}
+-
+ sub run_image_regression_tests {
+ my $suffix = $ENV{GDIMAGETYPE} || 'gd2';
+ print STDERR "# Testing using $suffix support.\n";
diff --git a/dev-perl/GD/metadata.xml b/dev-perl/GD/metadata.xml
index d88ba498bd37..a38a82b09765 100644
--- a/dev-perl/GD/metadata.xml
+++ b/dev-perl/GD/metadata.xml
@@ -12,6 +12,7 @@
<remote-id type="cpan">GD</remote-id>
<remote-id type="cpan-module">GD</remote-id>
<remote-id type="cpan-module">GD::Group</remote-id>
+ <remote-id type="cpan-module">GD::Image</remote-id>
<remote-id type="cpan-module">GD::Polygon</remote-id>
<remote-id type="cpan-module">GD::Polyline</remote-id>
<remote-id type="cpan-module">GD::Simple</remote-id>