summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/trollius/Manifest1
-rw-r--r--dev-python/trollius/trollius-2.0.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/trollius/Manifest b/dev-python/trollius/Manifest
index 2eb410cc63ef..45d1032d490a 100644
--- a/dev-python/trollius/Manifest
+++ b/dev-python/trollius/Manifest
@@ -1 +1,2 @@
DIST trollius-1.0.4.tar.gz 259188 SHA256 8884cae4ec6a2d593abcffd5e700626ad4618f42b11beb2b75998f2e8247de76 SHA512 f8df8c9f0034e6075e2a356a0bcfcd7908d98d8d14b07332a71de0115753e17335f5b8030c06c6b2a5b79437392ccf13f92d46155622f789b13c36d04c6d1f9e WHIRLPOOL 0cc57bee6be7a2bd8785decc406792c0d354dfc24f4a51b40d0de9557e212cbda738f9aab0a41fcb1ebe1a4b72986c09db1e243fd6ca3398f1df400e8c4ae6ad
+DIST trollius-2.0.tar.gz 273021 SHA256 a8e0e2d3a3193be3e0f113253f41675d2679d23c491f32b37f4e0a736f32a28f SHA512 457be3ac9b7dd036576e29ee754afe1289f864f0b4ebe166405f64574d094b75ebeb2fa18d1a5d48dbc03069bcb491e92b983c55a8acad8bf9f9471f0e659549 WHIRLPOOL 2ed7ba50d687e63f59ad0cef88df76ba354102aadfc5ef47342b0756ae7d6d87e4e94a55593eacdf61601ade1d5338339489db8001097d633acdc9fc9d119246
diff --git a/dev-python/trollius/trollius-2.0.ebuild b/dev-python/trollius/trollius-2.0.ebuild
new file mode 100644
index 000000000000..b15094c7a12c
--- /dev/null
+++ b/dev-python/trollius/trollius-2.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+inherit distutils-r1
+
+DESCRIPTION="A port of the Tulip project (asyncio module, PEP3156)"
+HOMEPAGE="https://github.com/haypo/trollius https://pypi.python.org/pypi/trollius/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+
+RDEPEND="virtual/python-futures[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ "${PYTHON}" runtests.py || die "Testing failed under ${EPYTHON}"
+}