summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/elasticsearch-py/Manifest1
-rw-r--r--dev-python/elasticsearch-py/elasticsearch-py-7.0.5.ebuild102
2 files changed, 103 insertions, 0 deletions
diff --git a/dev-python/elasticsearch-py/Manifest b/dev-python/elasticsearch-py/Manifest
index 051fd47a9ef0..ed59119126f2 100644
--- a/dev-python/elasticsearch-py/Manifest
+++ b/dev-python/elasticsearch-py/Manifest
@@ -3,3 +3,4 @@ DIST elasticsearch-oss-7.0.1-no-jdk-linux-x86_64.tar.gz 68787752 BLAKE2B 63864de
DIST elasticsearch-py-6.3.1.tar.gz 90047 BLAKE2B 765d0a34bd22067e07f4e862eb72f2b67bd0db3516abdf76cdc0d4f24de3db6941b4dbc6afb6315667d640514415cf08ff6de127c84ab36ef9bf062d4e687d55 SHA512 b975a6b446b760bf62289e855768a26b9e104aba9cd399cf275f59f2755efa00bd55c99a746751dad2f7a18f581a1b124c1bb9b91f5c3dc9fb00138c9d198aea
DIST elasticsearch-py-6.4.0.tar.gz 97217 BLAKE2B 376768fab9bd7b4efd98f8cc24d4bad700f9bd2f9013a794e28986ee80463e5854399124bfde43a9a43d6773ee5e546fc28077452d2daab6e2e25810c045a986 SHA512 bb9a2fad3ca002b25fa58585cffdadf847a078f72a5b24297d58e1d598103cb38155ff61fd5802be8ccfec96daec3119ecb490f876c07263f103fbf26f6dc6d4
DIST elasticsearch-py-7.0.2.tar.gz 102921 BLAKE2B 35ea3dd964a39caa594f380cea1508f0dea15486f1e0708f9daf3aa2e461429c76e0c7bf491a9aadb7187e30544597f6c41d20ff06b8b8d3b3b1655e6df387c9 SHA512 f91823dca2958fd0292ba623599d89138dd83ed2d41ecef1d5dcdd30a66c87db99d0576f41da15affd4e0027355eb20437e2dc104f98ffa86d0066d0b04b2590
+DIST elasticsearch-py-7.0.5.tar.gz 110079 BLAKE2B 89f5f7434fae0c4d20c1780c0979a419278fcaa23f75d5241d48c695905e566742fac5651387f0b1cb665ab6e9cb299406ee7f0157facc8c4cf2c1f1a4a3e5d7 SHA512 c4224cee6f7739ad932036f2afc6ed20ead16829d42f40b79e08d6714b4a247f019175739fb5a93bcea5bba391bd9f54cadcd31d42ff9411da414d08c140049b
diff --git a/dev-python/elasticsearch-py/elasticsearch-py-7.0.5.ebuild b/dev-python/elasticsearch-py/elasticsearch-py-7.0.5.ebuild
new file mode 100644
index 000000000000..f12fb68275e3
--- /dev/null
+++ b/dev-python/elasticsearch-py/elasticsearch-py-7.0.5.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy )
+ES_VERSION="7.0.1"
+
+inherit distutils-r1
+
+MY_PN=${PN/-py/}
+DESCRIPTION="Official Python low-level client for Elasticsearch"
+HOMEPAGE="https://github.com/elastic/elasticsearch-py"
+SRC_URI="https://github.com/elasticsearch/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz
+ test? ( https://artifacts.elastic.co/downloads/elasticsearch/elasticsearch-oss-${ES_VERSION}-no-jdk-linux-x86_64.tar.gz )"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples test"
+
+# tests fail in chroot
+# https://github.com/elastic/elasticsearch/issues/12018
+RESTRICT="test"
+
+RDEPEND=">=dev-python/urllib3-1.21.1[${PYTHON_USEDEP}]"
+
+DEPEND="test? ( ${RDEPEND}
+ >=dev-python/requests-2.0.0[${PYTHON_USEDEP}]
+ <dev-python/requests-3.0.0[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pretty-yaml[${PYTHON_USEDEP}]
+ virtual/jre:1.8 )"
+
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.3.1-r1"
+
+python_prepare_all() {
+ sed -e '/coverage/d' \
+ -e '/nosexcover/d' \
+ -i setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ emake -C docs -j1 man $(usex doc html "")
+}
+
+# FEATURES="test -usersandbox" emerge dev-python/elasticsearch-py
+python_test() {
+ ES="${WORKDIR}/elasticsearch-${ES_VERSION}"
+ ES_PORT="25124"
+ ES_INSTANCE="gentoo-es-py-test"
+ ES_LOG="${ES}/logs/${ES_INSTANCE}.log"
+ PID="${ES}/elasticsearch.pid"
+ export JAVA_HOME=$(java-config -g JAVA_HOME)
+
+ # run Elasticsearch instance on custom port
+ sed -i "s/#http.port: 9200/http.port: ${ES_PORT}/g; \
+ s/#cluster.name: my-application/cluster.name: ${ES_INSTANCE}/g" \
+ "${ES}/config/elasticsearch.yml" || die
+
+ # start local instance of elasticsearch
+ "${ES}"/bin/elasticsearch -d -p "${PID}" -Epath.repo=/ || die
+
+ local i
+ local es_started=0
+ for i in {1..20}; do
+ grep -q "started" ${ES_LOG} 2> /dev/null
+ if [[ $? -eq 0 ]]; then
+ einfo "Elasticsearch started"
+ es_started=1
+ eend 0
+ break
+ elif grep -q 'BindException\[Address already in use\]' "${ES_LOG}" 2>/dev/null; then
+ eend 1
+ eerror "Elasticsearch already running"
+ die "Cannot start Elasticsearch for tests"
+ else
+ einfo "Waiting for Elasticsearch"
+ eend 1
+ sleep 2
+ continue
+ fi
+ done
+
+ [[ $es_started -eq 0 ]] && die "Elasticsearch failed to start"
+
+ export TEST_ES_SERVER="localhost:${ES_PORT}"
+ nosetests -v || die
+
+ pkill -F ${PID} || die
+}
+
+python_install_all() {
+ use doc && HTML_DOCS=( docs/_build/html/. )
+ use examples && dodoc -r example
+ doman docs/_build/man/*
+ distutils-r1_python_install_all
+}