summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-print/cups/cups-2.0.3.ebuild1
-rw-r--r--net-print/cups/cups-2.0.4.ebuild1
-rw-r--r--net-print/cups/cups-2.1.2-r2.ebuild1
-rw-r--r--net-print/cups/cups-9999.ebuild1
-rw-r--r--net-print/cups/files/cups-2.0.3-cross-compile.patch30
5 files changed, 34 insertions, 0 deletions
diff --git a/net-print/cups/cups-2.0.3.ebuild b/net-print/cups/cups-2.0.3.ebuild
index 11d2f6999b6f..1b14320d6ac8 100644
--- a/net-print/cups/cups-2.0.3.ebuild
+++ b/net-print/cups/cups-2.0.3.ebuild
@@ -100,6 +100,7 @@ PATCHES=(
"${FILESDIR}/${PN}-2.0.2-rename-systemd-service-files.patch"
"${FILESDIR}/${PN}-2.0.2-systemd-socket.patch"
"${FILESDIR}/${PN}-2.0.1-xinetd-installation-fix.patch"
+ "${FILESDIR}/${PN}-2.0.3-cross-compile.patch"
)
MULTILIB_CHOST_TOOLS=(
diff --git a/net-print/cups/cups-2.0.4.ebuild b/net-print/cups/cups-2.0.4.ebuild
index 0a00f54ad525..cd8a5f102a53 100644
--- a/net-print/cups/cups-2.0.4.ebuild
+++ b/net-print/cups/cups-2.0.4.ebuild
@@ -100,6 +100,7 @@ PATCHES=(
"${FILESDIR}/${PN}-2.0.2-rename-systemd-service-files.patch"
"${FILESDIR}/${PN}-2.0.2-systemd-socket.patch"
"${FILESDIR}/${PN}-2.0.1-xinetd-installation-fix.patch"
+ "${FILESDIR}/${PN}-2.0.3-cross-compile.patch"
)
MULTILIB_CHOST_TOOLS=(
diff --git a/net-print/cups/cups-2.1.2-r2.ebuild b/net-print/cups/cups-2.1.2-r2.ebuild
index 1a45172f5176..49e827a2b142 100644
--- a/net-print/cups/cups-2.1.2-r2.ebuild
+++ b/net-print/cups/cups-2.1.2-r2.ebuild
@@ -100,6 +100,7 @@ PATCHES=(
"${FILESDIR}/${PN}-2.0.2-rename-systemd-service-files.patch"
"${FILESDIR}/${PN}-2.1.2-systemd-socket.patch"
"${FILESDIR}/${PN}-2.0.1-xinetd-installation-fix.patch"
+ "${FILESDIR}/${PN}-2.0.3-cross-compile.patch"
)
MULTILIB_CHOST_TOOLS=(
diff --git a/net-print/cups/cups-9999.ebuild b/net-print/cups/cups-9999.ebuild
index 45127ab418fe..b22cf63b2392 100644
--- a/net-print/cups/cups-9999.ebuild
+++ b/net-print/cups/cups-9999.ebuild
@@ -100,6 +100,7 @@ PATCHES=(
"${FILESDIR}/${PN}-2.0.2-rename-systemd-service-files.patch"
"${FILESDIR}/${PN}-2.1.2-systemd-socket.patch"
"${FILESDIR}/${PN}-2.0.1-xinetd-installation-fix.patch"
+ "${FILESDIR}/${PN}-2.0.3-cross-compile.patch"
)
MULTILIB_CHOST_TOOLS=(
diff --git a/net-print/cups/files/cups-2.0.3-cross-compile.patch b/net-print/cups/files/cups-2.0.3-cross-compile.patch
new file mode 100644
index 000000000000..d0893c31fa7b
--- /dev/null
+++ b/net-print/cups/files/cups-2.0.3-cross-compile.patch
@@ -0,0 +1,30 @@
+we don't actually install the generated html output, so no point in building
+them. this also helps cross-compiling because the tool to create the html
+uses $CC and has no logic for $BUILD_CC. simpler to disable than fix.
+
+--- a/man/Makefile
++++ b/man/Makefile
+@@ -73,7 +73,7 @@ MAN8 = cupsaccept.$(MAN8EXT) \
+ # Make everything...
+ #
+
+-all: $(MAN1) $(MAN5) $(MAN7) $(MAN8) html
++all: $(MAN1) $(MAN5) $(MAN7) $(MAN8)
+
+
+ #
+
+similarly, the genstrings tool is used to gather all the translatable strings
+in the code base for passing to gettext. in our builds, those strings already
+exist, so no point in running this tool.
+
+--- a/ppdc/Makefile
++++ b/ppdc/Makefile
+@@ -70,7 +70,6 @@ EXECTARGETS = \
+ TARGETS = \
+ $(LIBTARGETS) \
+ $(EXECTARGETS) \
+- genstrings
+
+
+ #