summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www-apps/moodle/Manifest1
-rw-r--r--www-apps/moodle/moodle-3.6.1.ebuild123
2 files changed, 124 insertions, 0 deletions
diff --git a/www-apps/moodle/Manifest b/www-apps/moodle/Manifest
index fa341a753c1c..0f54d9540828 100644
--- a/www-apps/moodle/Manifest
+++ b/www-apps/moodle/Manifest
@@ -2,3 +2,4 @@ DIST moodle-3.1.15.tgz 38055035 BLAKE2B d55f523fce2f7193330665132b4d7faf6a7a698c
DIST moodle-3.3.9.tgz 45123816 BLAKE2B 0e23668fb6ac536a1a87067fc9574424c33934402184ffc6f25f48f7e87c70fb0d9b25bb12b46320d54968ddb8b337471be7b5795369585ce4c488f93168f6d9 SHA512 6150a4c0f4a85ac508d2da9b35fd506eca614c3a44d582096fdecd113899a72481507ce85101505570e0e8237f7af744e3d7a8cf990cf8b250f5ac335ebae1de
DIST moodle-3.4.6.tgz 45961570 BLAKE2B 49a20412b386cc3f463dd3be58dc56f50821298d36109889b3eb092d39f4dfe477dfbbf1ea3f1b6ce8076b4d4dca21efc00e7d772b0ced395139d76e56759482 SHA512 2afa7facb2068c63d0a1bd42da40a1cb688a1bcdedc5287e59633bb085f96c65598396f03b99b35c9aa3769463dea316584ce3793978101989fc53f53140ff04
DIST moodle-3.5.3.tgz 46645219 BLAKE2B bd1aa2ae73f807c3b8a0e341893c7b004761e147fe42eac615153ae1ee7fa4bf9268e160a14ab1ac62dfe2c5e462d042cb30b725d6a28844e4749492b6a9b193 SHA512 130d1c30acb78452021f4fd5c0d29bfc4c938993e7d0cf3b2fdf13061fa993f9cebc7214f287e62ceb13bfd5999c12132a45fd4aec5efe8c25078dfe97bee861
+DIST moodle-3.6.1.tgz 47660920 BLAKE2B 3dba1adb2a2c9926a0efb1942df4239a020c2c2d661a6a2a6825acc70b6e7aab69afb4f0f297cd316fd5f693ab711cccea8bc5c68fa1b72288297b8d00791088 SHA512 79cf5127748e6511101b9f802165eefbe6dafbe89806e8616902765d14481af0b6ba06757be5fecd343bda7dde261c58018f940254549decc66452415a99ab9d
diff --git a/www-apps/moodle/moodle-3.6.1.ebuild b/www-apps/moodle/moodle-3.6.1.ebuild
new file mode 100644
index 000000000000..dea9710e1e62
--- /dev/null
+++ b/www-apps/moodle/moodle-3.6.1.ebuild
@@ -0,0 +1,123 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit versionator webapp
+
+AVC=( $(get_version_components) )
+MY_BRANCH="stable${AVC[0]}${AVC[1]}"
+
+DESCRIPTION="The Moodle Course Management System"
+HOMEPAGE="https://moodle.org"
+SRC_URI="https://download.moodle.org/${MY_BRANCH}/${P}.tgz"
+S="${WORKDIR}/${PN}"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+#SLOT empty due to webapp
+
+DB_FLAGS="mysqli?,mssql?,postgres?"
+DB_TYPES=${DB_FLAGS//\?/}
+DB_TYPES=${DB_TYPES//,/ }
+
+AUTHENTICATION_FLAGS="imap?,ldap?,odbc?"
+AUTHENTICATION_MODES=${AUTHENTICATION_FLAGS//\?/}
+AUTHENTICATION_MODES=${AUTHENTICATION_MODES//,/ }
+
+PHP_REQUIRED_FLAGS="ctype,curl,iconv,json,session,simplexml,xml,zip"
+PHP_OPTIONAL_FLAGS="gd,intl,soap,ssl,tokenizer,xmlrpc"
+PHP_FLAGS="${PHP_REQUIRED_FLAGS},${PHP_OPTIONAL_FLAGS}"
+
+IUSE="${DB_TYPES} ${AUTHENTICATION_MODES} vhosts"
+REQUIRED_USE="|| ( ${DB_TYPES} )"
+
+# No forced dependency on
+# mssql? - lives on a windows server
+# mysql? ( virtual/mysql )
+# postgres? ( dev-db/postgresql-server-9* )
+# which may live on another server. These USE flags affect the configuration
+# file and the dependency on php. However other dbs are possible. See config.php
+# and the moodle documentation for other possibilities.
+DEPEND=""
+RDEPEND="
+ >=dev-lang/php-7.0[${DB_FLAGS},${AUTHENTICATION_FLAGS},${PHP_FLAGS}]
+ virtual/httpd-php
+ virtual/cron"
+
+pkg_setup() {
+ webapp_pkg_setup
+
+ # How many dbs were selected? If one and only one, which one is it?
+ MYDB=""
+ DB_COUNT=0
+ for db in ${DB_TYPES}; do
+ if use ${db}; then
+ MYDB=${db}
+ DB_COUNT=$(($DB_COUNT+1))
+ fi
+ done
+
+ # REQUIRED_USE above guarantees that ${DB_COUNT} cannot be zero
+ #if [[ ${DB_COUNT} -eq 0 ]]; then
+ # eerror
+ # eerror "No database selected in your USE flags,"
+ # eerror "You must select at least one."
+ # eerror
+ # die
+ #fi
+
+ if [[ ${DB_COUNT} -gt 1 ]]; then
+ MYDB=""
+ ewarn
+ ewarn "Multiple databases selected in your USE flags,"
+ ewarn "You will have to choose your database manually."
+ ewarn
+ fi
+}
+
+src_prepare() {
+ rm COPYING.txt
+ cp "${FILESDIR}"/config-r1.php config.php
+
+ # Moodle expect pgsql, not postgres
+ MYDB=${MYDB/postgres/pgsql}
+
+ if [[ ${DB_COUNT} -eq 1 ]] ; then
+ sed -i -e "s|mydb|${MYDB}|" config.php
+ fi
+
+ eapply_user
+}
+
+src_install() {
+ webapp_src_preinst
+
+ local MOODLEDATA="${MY_HOSTROOTDIR}"/moodle
+ dodir ${MOODLEDATA}
+ webapp_serverowned -R "${MOODLEDATA}"
+
+ local MOODLEROOT="${MY_HTDOCSDIR}"
+ insinto ${MOODLEROOT}
+ doins -r *
+
+ webapp_configfile "${MOODLEROOT}"/config.php
+
+ if [[ ${DB_COUNT} -eq 1 ]]; then
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+ else
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-nodb-en.txt
+ fi
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ einfo
+ einfo
+ einfo "To see the post install instructions, do"
+ einfo
+ einfo " webapp-config --show-postinst ${PN} ${PVR}"
+ einfo
+ einfo
+}