summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-video/gaupol/Manifest1
-rw-r--r--media-video/gaupol/gaupol-1.9.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/media-video/gaupol/Manifest b/media-video/gaupol/Manifest
index 20bd300ebc39..615296b500f9 100644
--- a/media-video/gaupol/Manifest
+++ b/media-video/gaupol/Manifest
@@ -1 +1,2 @@
DIST gaupol-1.8.tar.gz 558627 BLAKE2B a7243310b97fe7187311585762faaff512364ca043630eb43c1ee99c55fa5400e14698e391b410b67f70f1bc7a741adb0737868d7b40c868bb4c6badacd14fb1 SHA512 a6b65316b5750a4d636b39b75393b0b2f2c44d978f1fc8cc3bd2cd2d2bcf9ba68d0161afb41bdca5b381ec39e5a2e06440f4f4676f344019966b297c4112e691
+DIST gaupol-1.9.tar.gz 579382 BLAKE2B c326e800ebd56bab53757d13e075c7499d9b37c6677a3f2ef710e71ab427bc9d502d1539778e87625e43a6218a358b15dfc3c84fd22b42e95d808fc8495feb43 SHA512 c115409afe68a0981f7c29e5d6d3e23950081f186b74de460045de9976a6c7a674701d316214ee2b91bc59f1dd856fdc9cf999e328aba8abeb8eaf71911c68d2
diff --git a/media-video/gaupol/gaupol-1.9.ebuild b/media-video/gaupol/gaupol-1.9.ebuild
new file mode 100644
index 000000000000..9a01c44bbd27
--- /dev/null
+++ b/media-video/gaupol/gaupol-1.9.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+DISTUTILS_USE_SETUPTOOLS=no
+
+inherit distutils-r1 virtualx xdg-utils
+
+DESCRIPTION="A subtitle editor for text-based subtitles"
+HOMEPAGE="https://otsaloma.io/gaupol/"
+SRC_URI="https://github.com/otsaloma/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="spell"
+
+RDEPEND="
+ app-text/iso-codes
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ x11-libs/gtk+:3[introspection]
+ spell? ( app-text/gspell[introspection] )
+"
+BDEPEND="
+ sys-devel/gettext
+ test? (
+ app-dicts/myspell-en
+ app-text/enchant[hunspell]
+ app-text/gspell[introspection]
+ )
+"
+
+distutils_enable_tests pytest
+
+DOCS=( AUTHORS.md NEWS.md TODO.md README.md README.aeidon.md )
+
+python_test() {
+ virtx pytest -vv
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog "The integrated video player requires media-plugins/gst-plugins-gtk."
+ elog ""
+ elog "External video previewing support requires MPV, MPlayer or VLC."
+ if use spell; then
+ elog ""
+ elog "Spell-checking requires a dictionary, any of app-dicts/myspell-*"
+ elog "or app-text/aspell with the appropriate L10N variable."
+ elog ""
+ elog "Additionally, make sure that app-text/enchant has the correct flags enabled:"
+ elog "USE=hunspell for myspell dictionaries and USE=aspell for aspell dictionaries."
+ fi
+ fi
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}