summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/cython/cython-0.28.2.ebuild2
1 files changed, 2 insertions, 0 deletions
diff --git a/dev-python/cython/cython-0.28.2.ebuild b/dev-python/cython/cython-0.28.2.ebuild
index 23c25226c41a..eecc7a4ba326 100644
--- a/dev-python/cython/cython-0.28.2.ebuild
+++ b/dev-python/cython/cython-0.28.2.ebuild
@@ -52,6 +52,8 @@ python_compile_all() {
python_test() {
tc-export CC
+ # https://github.com/cython/cython/issues/1911
+ local -x CFLAGS="${CFLAGS} -fno-strict-overflow"
"${PYTHON}" runtests.py -vv --work-dir "${BUILD_DIR}"/tests \
|| die "Tests fail with ${EPYTHON}"
}