summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/noiseprotocol/Manifest1
-rw-r--r--dev-python/noiseprotocol/metadata.xml13
-rw-r--r--dev-python/noiseprotocol/noiseprotocol-0.3.1.ebuild26
3 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/noiseprotocol/Manifest b/dev-python/noiseprotocol/Manifest
new file mode 100644
index 000000000000..5d810f0b2e08
--- /dev/null
+++ b/dev-python/noiseprotocol/Manifest
@@ -0,0 +1 @@
+DIST noiseprotocol-0.3.1.gh.tar.gz 308734 BLAKE2B 952bc1f7615c209d031104a54f4e31fefa5deac064c70d589198bb8e82c1847c529e93a582d5cb9210aa199d0ea0ecb878b9d81318bc27c90e93027e8000f2a9 SHA512 4b9ebbf891366564238922355fe2c557830f11f8933c13f7abf4e035167adaa83cb8f30897b500227f9ac8ed46a8ae752e83a0088456edf8696626c4bd4a149e
diff --git a/dev-python/noiseprotocol/metadata.xml b/dev-python/noiseprotocol/metadata.xml
new file mode 100644
index 000000000000..befefe8b2874
--- /dev/null
+++ b/dev-python/noiseprotocol/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>tamiko@gentoo.org</email>
+ <name>Matthias Maier</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">noiseprotocol</remote-id>
+ <remote-id type="github">plizonczyk/noiseprotocol</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/noiseprotocol/noiseprotocol-0.3.1.ebuild b/dev-python/noiseprotocol/noiseprotocol-0.3.1.ebuild
new file mode 100644
index 000000000000..e564c8306957
--- /dev/null
+++ b/dev-python/noiseprotocol/noiseprotocol-0.3.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+DESCRIPTION="Implementation of Noise Protocol Framework. Compatible with revisions 32 and 33."
+HOMEPAGE="https://pypi.org/project/noiseprotocol"
+SRC_URI="https://github.com/plizonczyk/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/cryptography[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ default
+ rm -r "examples" || die "rm failed"
+}