summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-libs/tg_owt/tg_owt-0_pre20210422.ebuild4
-rw-r--r--net-im/telegram-desktop/telegram-desktop-2.7.4.ebuild3
2 files changed, 6 insertions, 1 deletions
diff --git a/media-libs/tg_owt/tg_owt-0_pre20210422.ebuild b/media-libs/tg_owt/tg_owt-0_pre20210422.ebuild
index 9861bd952328..0c5ed6f7895c 100644
--- a/media-libs/tg_owt/tg_owt-0_pre20210422.ebuild
+++ b/media-libs/tg_owt/tg_owt-0_pre20210422.ebuild
@@ -42,11 +42,12 @@ S="${WORKDIR}/${PN}-${TG_OWT_COMMIT}"
src_unpack() {
unpack "${P}.tar.gz"
- cd "$S/src/third_party/libyuv" || die
+ cd "${S}/src/third_party/libyuv" || die
unpack "libyuv-${LIBYUV_COMMIT}.tar.gz"
}
src_prepare() {
+ # https://github.com/desktop-app/tg_owt/pull/55
eapply "${FILESDIR}/Allow-using-packaged-third_party.patch"
# We aren't installing any third_party headers
@@ -57,6 +58,7 @@ src_prepare() {
# Remove screen_drawer files that cause linking errors
# (not used right now I don't think, maybe in a future version)
+ # https://github.com/desktop-app/tg_owt/issues/58
sed -i -e '/desktop_capture\/screen_drawer\.cc/d' \
-e '/desktop_capture\/screen_drawer_lock_posix\.cc/d' CMakeLists.txt || die
diff --git a/net-im/telegram-desktop/telegram-desktop-2.7.4.ebuild b/net-im/telegram-desktop/telegram-desktop-2.7.4.ebuild
index 63ffd479879d..609781f96cb7 100644
--- a/net-im/telegram-desktop/telegram-desktop-2.7.4.ebuild
+++ b/net-im/telegram-desktop/telegram-desktop-2.7.4.ebuild
@@ -66,7 +66,10 @@ REQUIRED_USE="
S="${WORKDIR}/${MY_P}"
PATCHES=(
+ # https://github.com/desktop-app/cmake_helpers/pull/91
+ # https://github.com/desktop-app/lib_webview/pull/2
"${FILESDIR}/tdesktop-2.7.3-disable-webkit-separately.patch"
+ # https://github.com/desktop-app/lib_webview/commit/0b4100d7cecc4e748c51f3f51ebfd1392ec3978a
"${FILESDIR}/tdesktop-2.7.3-webview-include-gdkx.patch"
)