summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ruby/ruby-opengl/ruby-opengl-0.10.0.ebuild48
1 files changed, 0 insertions, 48 deletions
diff --git a/dev-ruby/ruby-opengl/ruby-opengl-0.10.0.ebuild b/dev-ruby/ruby-opengl/ruby-opengl-0.10.0.ebuild
deleted file mode 100644
index ee4729a2f4b2..000000000000
--- a/dev-ruby/ruby-opengl/ruby-opengl-0.10.0.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-USE_RUBY="ruby24 ruby25 ruby26 ruby27"
-
-RUBY_FAKEGEM_RECIPE_DOC="rdoc"
-
-# Two tests fails but the README already indicates that this may not
-# work. Additionally these tests require access to video devices such as
-# /dev/nvidiactl.
-RUBY_FAKEGEM_TASK_TEST=""
-
-RUBY_FAKEGEM_NAME="opengl"
-
-RUBY_FAKEGEM_EXTRADOC="History.md README.rdoc"
-
-inherit multilib ruby-fakegem
-
-DESCRIPTION="OpenGL / GLUT bindings for ruby"
-HOMEPAGE="https://github.com/larskanis/opengl"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~hppa ppc ppc64 x86"
-
-IUSE=""
-
-DEPEND+=" virtual/opengl
- media-libs/freeglut"
-RDEPEND+=" virtual/opengl
- media-libs/freeglut"
-
-each_ruby_configure() {
- ${RUBY} -Cext/opengl extconf.rb || die
-}
-
-each_ruby_compile() {
- emake -C ext/opengl V=1
-
- cp ext/*/*$(get_modname) lib/opengl/ || die
-}
-
-all_ruby_install() {
- all_fakegem_install
-
- dodoc -r examples
-}